WinXP; Multiple users logged in: Tray Icon shows Disabled (red circle 'cancel')

When I log in to my winxp machine, everything is peachy with CIS.

But then when I use the WinXP “fast user switching” the tray icon for subsequent simultaneous users shows the “firewall disabled” icon. That being the white shield overlaid with a red “cancel” or “no” symbol (circle with slant bar across – see the image at the bottom of this post). ((FYI, yeah my cpu is 100% on folding[at]home))

As far as I can tell everything else is normal. Right-Clicking on that icon shows that none of the Security Levels are disabled (Antivirus, Firewall, Defense+). The program operates as normal, updates are possible, I can see active network connections, etc. It seems to be just the tray icon is odd.

I hope to bring this to the developer team’s attention just in case there’s some other issues going on that I can’t observe readily.

Other users: Can you reproduce this in XP? In Vista? In Win7? I would be interested to hear from you as well.

Steps to reproduce (using “switch user” all but first login):
0. restart computer, just to be consistent

  1. login user1 in winxp, let startup stuff load, see normal tray icon
  2. use to login a simultaneous user2 session
  3. notice tray icon is the disabled status one
  4. notice also traffic is not indicated, of course, in the tray icon.

?. somehow I just now got the user1 icon showing disabled also, after doing stuff in the user2’s CIS interface.

Confused, considering harmless for now. Please correct me if that’s an incorrect assumption. :o)

[attachment deleted by admin]

Does the following trick help you out? Do this for all accounts.

Try updating the Comodo Internet Security Helper Service (control panel, admin tools, services, right click on “Comodo Internet Security Helper Service”, properties). The logon Tab for the Service should currently show Local System Account and Allow service to interact with Desktop. Set This Account with your Logon ID and Password (+Confirm) and then reboot.

Welllllll, I guess I’ll add my situation here. Beginning today (and actually after switching out my DSL modem for a new one of the same make/model…old one over-heated…anyway) I just plugged in my new modem, waited for it to settle down with my ISP, booted up this computer and I also have the broken circle on the status bar icon. According to the main window it states that all is good and happy…except the red circle.
I don’t switch between users etc… just plain ol’ me running this thing (as admin)… so, how would a modem change-out affect Comodo. Also, I’m just running the free Comodo firewall.

Thanks for your help ALL!

Thanks! This worked perfectly for the problem I was having with the 2 login accounts and one having the “no” red icon on the shield…

Same issue here, but i posted in wrong forum. i will request the moderators to move it to this forum.

  • In my case story is diffrent. when I log into system( after powering ON) to limited user account I get this Icon.

However the problem is solved when i log off and log back. ( I am not doing any fast user switching)

I am attaching the screenshot for devs to see it



[attachment deleted by admin]

Try to set cfp.exe and cmdagent.exe to run as admin. Does that solve your problem?