WinXP fast user switch and Defense+ is not functioning properly

I have WinXP SP3 + latest updates+ latest free Comodo firewall.

When I log to second admin account and then log back to first admin account, Comodo Firewall tray icon shows error and says Defense+ is not functioning properly. I run diagnostics, but it doesn’t find anything. If I shutdown the firewall and start again, error is gone, but it comes back everytime when I switch to another account and then back.

Found an old topic about this issue where some moderator advised to go to services list under admin tools and put account id and password, but it doesn’t work. However, the services list shows only one “log on as” account although the moderator advised to do this for all accounts. I tried with inputting both account details and then click OK, it didnt work. Second time I logged to first account, set account details, restarted, logged in second account, set account details, restart, didn’t work. Services list always show same account name in “Log on as”, no matter which account I have logged at the moment.

This is a known issue and is number 154 in the bug tracking system.

You can normally resolve this by doing a full log off and on.

Apologies for the inconveniuence

Mouse

Sorry 164

Mouse