Windows XP SP3 Modified Dates Changed to Last Accessed Dates when Comodo Firewal

I’m still running Windows XP SP3 on a couple of machines for which I’m unable to update (hardware cannot handle). I use these for network backups, etc.

I started having issues that, after trial and error, I’ve traced back to Comodo Firewall. The last installation I grabbed was called “cfw_installer_6106_53.exe”.

The issue I’m having is when files are copied, whether from C-drive to D-drive for backup, or to another machine (also for backup), a certain number of files (maybe about 10%, but I’m guessing as to percentage) have their Last Modified dates changed during the file copy process. When that occurs, the file’s Modified date takes the current date/time when the copy process occurred (e.g. Last Accessed time stamp).

Finally found that if I uninstalled Comodo Firewall, I no longer have the issue of corrupt [Last Modified] date/time stamps.

I think this is most likely a bug in the Firewall program causing this, but I’ve Googled for answers over the last weeks to no avail. I finally was closing and/or uninstalling various programs and finally tracked it back to Comodo.

Anyone have any ideas as to why this would be occurring? Or maybe if there’s a better version that will not interfere with the Modified date/time stamp for files being copied?

known issue

I wondered if it could be a known issue, but the issue NEVER showed up in any google search over the last few weeks. I spent a lot more time today really trying to track it down.

Is there a solution? One poster said they went back to v7 of Comodo (which I may also look for an older version to test the resolution, but I’m no longer having the time stamp issue since uninstalling Comodo).

there are 2 solutions:

  1. go back to version 7

  2. use the 8.2 beta which allows you to disable alternate data streams which causes this issue.

Thanks, I’ll roll back to an earlier version (v7) and test that out. If no issues, I’ll stay at that version for now.

since this is a known bug im going to move this report to resolved.