Windows XP SP2 not restarting after installing CFP (V3.0.21.329 X32)

I have recently been trying to reinstall CFP (the latest version available, x32) on Windows XP. After installation, I restart the computer and it gets stuck on the black Windows screen indefinitely (I have left it there for 20 minutes). I can restart and enter Safe Mode to remove the Firewall, and Windows starts fine.

This occurs with or without Defence+ enabled. It is most likely due to registry entries left over from a previous install (I removed it a while ago for reasons I have since forgotten, and am now unable to reinstall it). I haver tried cleaning the registry with CCleaner.

I have AVG 7.5 installed as an antivirus. I am a full administrator. There is no other, and has not been another firewall installed on this computer.

Any help appreciated…

On some computers the Comodo Uninstaller leaves a couple of directories of files on the C: drive.

These are:
C:/Program Files/Comodo
C:/Documents and Settings/All Users/Applicaton Data/Comodo
C:/Documents and Settings/(username)/Applicaton Data/Comodo

Try removing these or searching your computer for anything named “Comodo” and deleting it then running CCleaner before attempting to reinstall.

(I should copy and paste this message. Seems a lot of people are having reinstall issues.)


Thanks, I’ll try that. Very quick reply

Ive removed those folders, and done a search. However, it still won’t install.

Any other ideas?

Hmm… I’ll need to look into it further. (Quick Reply)

You might try making sure that (Stop All Activities until comodo fully loaded) is un-ticked under the Defense+ security level and also exiting from Comodo Firewall before uninstalling it.

Hope this provides further help.


No help there… Take your time.

Not sure what you mean by the (Stop All Activities until comodo fully loaded) check box.

Additional info: I originally removed the firewall because Windows Firewall wasn;t detecting it, and it had the message that it wasn’t functioning properly, so I tried a reinstall (and my computer wouldn’t restart). Not sure what the problem was though.

CPF3 Doesn’t Automatically disable Windows Firewall. You have to do that Manually before you install CPF3.

Just finished my lunch but I’ll be online later tonight (BSD (British Summertime) = GMT+1


I’m new to this forum. I’m a newbie when it comes to computers. I’m having the same problem but I have Vista. I could really use some help please. When I boot up my computer, I get a black screen with the mouse pointer and that’s it. The mouse pointer doesn’t even move. So I’ve just been unplugging the computer and going into safe mode and tried to uninstall Comodo and I get this error message ‘Could not load C:\programfiles\comodo\firewall\cfpres.dll PLease check if application install has this file. Aborting application.’
Every time I try to open Comodo, I get this message. I tried add/remove programs and that didn’t work. I ran CCCleaner and I get the same message. And in safe mode, I can’t get dsl for the internet.

Look for that file in the firewall repair folder and move it to the specified location.


I’m still unable to find a solution to your issue with the information you’ve provided. Can you tell me what other programs you’re running on your machine? Download Managers etc? Have you tried disabling or uninstalling AVG or any system management software you have running?

Perhaps there’s some sort of conflict. You are running as an Administrator instead of Limited User aren’t you?


Maybe you can try to edit the boot.ini and add the /sos option after the bootloader command line.

See the url for additional details

Maybe this will point you to the conflicting driver ?
The /sos option will show you the drivers being loaded, maybe the last one to show is de conflicting one ?

Then you could try to disable this driver temporarily with Autoruns

Note: This won’t work on Vista because it uses an other bootloader (BDC).

Sorry about late reply.

I am an Admin account. I have installed with Windows Firewall enabled and disabled.

I’ll try disabling AVG. I can’t think of any other software that would conflict.

Actually, I have Blue Coat K9 Web Protection installed. Maybe that is conflicting?

Good news. After uninstalling AVG and BlueCoat, then my computer successfully restarted. Not sure which of the products was causing a problem…

EDIT: Blue Coat was definitely causing the problem (reinstalling it prevented me from restarting). There is some compatibility issues between Comodo and Blue Coat (

Great news that you’ve managed to find a solution!

Having had BlueChip installed explains everything.

Let me know if you have anything else you need help with.


Hi, It’s me again. I uninstalled AVG and that seemed to allow the computer to boot up normally. But I’m still getting the error message 'could not load c:\progamfiles\comodo\firewall\cfpres.dll Please check if application install has this file. Can someone help me to resolve this. I need something easy to understand. To be honest I didn’t understand the other responses or even how to implement them. Thanks again.

Hi again,
Did you delete the leftover Comodo files and directories and cleaned the registry before reinstalling CPF?

You can clean your registry using ccleaner found at which will remove any invalid entries in your registry and clear any temporary files you have. (In the Settings tab on ccleaner click advanced and uncheck “Only delete temp files older than 48 hours”.


You need to copy it from the repair folder to the folder above the repair folder.
Screenshot below.

[attachment deleted by admin]

Hi Eric,
Thanks for your response. I did this but keep getting the same error message. I even tried to do a system restore to before I had this problem and it said it couldn’t complete it because there was some type of error.


Hi Dennis,
Thanks for your response. I went to programs and the uninstall files (I have Vista) and whenever I clicked on Comodo, I got the same error message. I’m really at a loss.

Are you running vista in UAC mode ? could be your copy is stored in so called “virtualstore”.

Check the following folder, if it’s copied here then the system won’t find it at boot time !
C:\Users[b]YourUserIDHere[/b]\AppData\Local\VirtualStore\Program Files\COMODO\Firewall

Try to temporarily disable UAC or copy the file in safe mode.