Windows Update

Hello, its my first post in here! And I did read a lot in these forums trying to solve some problems that appeared to me with the comodo firewall.

I formated my Laptop recently and installed comodo firewall and a anti-virus, (that was two days ago). Well, it wouldnt allow me to update windows giving a 0x80072EE2 error (also wouldnt allow me to sync the windows clock with internet), thats a problem, so I uninstalled it. Then I updated windows update thing and installed comodo again since I wanted to surf the net… after that I could manually update windows just fine and I thought the problem was gone! =D

The problem reappeared after I downloaded and installed everything from windows update, because then it wouldnt allow me to manually connect to it anymore. And the more disturbing thing is that shutting down the firewall wouldnt change that. I even disabled everything on the firewall and closed every process related to it. And it wouldnt give me a 0x80072EE2 error.

It would appear at this point that its not comodo firewall who causes that, but the fact is: when I uninstall it everything works… reinstalling it makes me unable to get updates again, even with the firewall turned off. (I looked in the logs and apparently no connections were being blocked! =O)

I have no clue about why is this happening! I only know that I dont want to have to uninstall comodo firewall everytime I want to look for updates. :frowning:
Im still using it for now btw. =D

I wonder if you guys could help me… when I get back from work I could get windows update log and some screenshots as well.

Edit: Im running windows xp service pack 2 and AOL active virus shield.

Hi Khe, welcome to the forums.

I’m sorry you’re having problems… unfortunately if it does not work with the CFP Security Level of Allow All, then CFP isn’t responsible & uninstalling it will have no impact. You shouldn’t exit CFP processes, as it might think it is being attacked… the business end of CFP is its drivers and they are still loaded & running when you exit/disable processes/services. MS have KB URL on this 0x80072EE2 error here.

Failing that, there is a utility called DAF, that fixes WU problems, amongst other things. I’ll post more if you need it.

I hope that helps.

Edit: Im running windows xp service pack 2 and AOL active virus shield.

Possible cause of trouble? It wouldn’t be the first time the KAV engine interfered…

What do you think, kail?


Absolutely, I forgot AOL AV was KAVS. First 1 impacting Windows Update?

Not sure. But if there’s no log entries of anything being blocked, Allow All does not impact the situation in a positive way, and yet the connection is just not occurring, I’d be looking in that direction. The symptoms fit the ‘crime.’


Absolutely, I forgot AOL AV was KAVS. First 1 impacting Windows Update?

Yay I’m the first! XD

Alright I came home and closed AOL AV and closed its processess too… it didnt work.

Now I just uninstalled it… and everything works again! :BNC

So it seems that AOL AV has compatibility issues with comodo firewall…

But that kinda doesnt solve my problem because I cant have my favorite free firewall with my favorite free anti-virus… but at least now I know what causes it. =)

Unfortunately we (the Mods) no nothing… (gotta say it with an accent of course ;))… We know that some versions of KAVs refuse to install with CFP 2.4 at present and that CFP 2.4 (not sure about CFP3A1) is actively incompatible with KIS & later versions of KAVs. But, neither Comodo or Kaspersky have said what is going on. I can only suggest that you go to Comodo Support, register on their system & raise a ticket on this issue. And do likewise for Kaspersky. We’d be very grateful if you could post any feedback that you might receive here, thanks.


What we’ve seen happen frequently is that a user has KAV (or the AOL version) installed, and tries to install CFP. KAV tells them not to. Or, CFP is installed, they try to install KAV, and KAV insists they must uninstall CFP. Third is that both are installed, and CFP doesn’t work properly.

I understand from some users that Kaspersky (perhaps the forums? I’m not sure, there) has published a list of firewalls with which their AV will work, and suggest their users try those.

I personally think that a lot of this comes from installing while the other applications are actively running. However, I have no solid quantification of that. IF you are willing to make a few test runs, I would suggest that you try:

Since the AV is currently uninstalled, clean out the registry (you can use a cleaner like CCleaner or RegSeeker if you like, to remove rogue/leftover entries), and reboot. Remove any remaining files for the AV, and clean out temporary files. Reboot.

Disconnect your computer from the internet, and close CFP (right-click the systray icon and select Exit). Go to Start/All Programs/Comodo/Firewall/Uninstall, and uninstall the FW completely. Note: If you have detailed settings you would like to retain, you can use the script located in this thread (prior to uninstall) to back those up and import (after reinstall)…,2366.0.html Once again, after reboot, clean out registry and any leftover files. Reboot. (Note: You’re still disconnected from the internet)

Turn off any other active security software - antispyware, registry guard, etc

Reinstall the firewall, using the Automatic installation process (rather than Advanced, which requires a manual configuration). Reboot. Import your settings if you previously exported them, as per the instructions in that thread. Now Close the FW GUI again, just as before (right-click, exit).

Reinstall the AV. If it has a “webshield” type of module, deactivate it; try not to even install it, if possible - it will most likely interfere with the FW, as it’s trying to do some of the same thing. Reboot after the install completes.

This should re-enable the FW and any other security software you have turned off. Then see how that works.

If they’re going to play together without programming intervention, I personally think that’s the best chance. I know the KAV forums say to install the AV first, then the FW, and some users report success with that, but too many report that it tells the user they can’t install the FW, or if it does install, the FW doesn’t work. I have had reports from some that having the FW installed first works, but I do not know how “clean” of an installation process they were going through.

Anyway, that’s up to you. If you feel like spending some more time on it, I’d love to hear your results.


PS: kail, you left out the part about chocolate - that’s crucial to the “we know nothing” scenario. Come on, man! You gotta do the quotes right! :wink:

Little Mac… I just tried, I uninstalled both and used ccclean then installed both the firewall with the antivirus with everything shut. I did that twice in orders. And the update works now, but it wont allow me to upload files anymore! Ack there is really something wrong about it.

Then I disabled them (set allow all in comodo and turned off file scan on avs) and still not work. The only way is to uninstall one of the two. =(

Bummer! I’m really sorry to hear that. For one thing, it’d be great for you to run both, and not have to choose… and also it’d be great for us to have a solid set of steps to take, that have been shown to work.

Given all the varied reports and results from different users, it really sounds like something that creates a different incompatibility on different systems. In other situations like that, it has frequently involved other applications/hardware as well, causing the environment to be just a little bit different… Very difficult to track down.

Thanks for giving it a concerted effort, Khe, your willingness to help out is greatly appreciated. Do you feel like trying it the other way? Uninstall, clean out, install KAV; then turn it off and install the FW?