Windows Security Icon Says Comodo Firewall Turned Off.....

Apologies I posted this under frequently asked questions which I think is an error. Hence repost here

I have Win XP Home SP2 fully updated with Comodo Firewall 2.4 .18. 184. Windows firewall turned off.

When I boot up my pc and the various start up icons load in the system tray. I get the windows security icon loading in the system tray also giving the above warning. (Comodo Firewall Turned off…) When the Comodo Firewall icon loads the Security Icon disappears.

If I check the Security Centre in Win XP Ctrl Panel Comodo Firewall is recognised.

I have seen a number of posts relating to Comodo Firewall not being recognised and the solution concerning stopping and starting net Winmgmt and deleting the repository folder in system32/wbem.

This worked in the sense that the system icon stopped loading at start up but the Firewall was not recognised directly in security centre. Also if I removed the Comodo Icon from the system tray the windows security icon failed to alert that Comdo Firewall was not functional.

A more detailed solution in the forums archives involved the above procedure AND involving RegSvr32 and RegServer, only went full circle and put back the original problem as in the title of this thread

Can anyone help solve this irritating time delay between Comodo system tray icon loading and the security centre warning?



Don’t touch anything. Ignore it.
Security center, ahem, is probably alerting that Comodo’s GUI isn’t detected. It’s also probably true, maybe you have many programs on startup that delay CFP’s GUI.

But that’s only the GUI, the driver should be working with the rules you made.
The driver is the one that does the work. The GUI is where you see the logs and change rules.

When the Comodo Firewall icon loads the Security Icon disappears.
This is the GUI loading.

Either cut back on startup programs, or IGNORE it.

Hi All from a Comodo newbie,
I’ve just installed CPF onto my XP SP2 PC (The Windows firewall seems to have served me well enough over the years (along with Avast!) but I keep reading about the old “outbound” protection thing so I thought I’d give it a try). Anyway, I’m also getting this warning that Comodo isn’t running. The warning disappears once Comodo is running. It’s all very well saying “ignore it” but it seems like the integration with Microsoft Security Center is lacking somewhere? I agree it’s not a huge issue but It’s an annoyance. What’s the answer?

It’s only the GUI that can sometimes not load as fast at startup, however the firewall will be up and running. Unfortunately Windows Security Centre just looks at the GUI, so you could always disable the Security Centre from showing those alerts.

To disable the Security centre from alerting you about the firewall, open the security centre from the control panel, then under resources, select “Change the way Security Centre alerts me” and then untick the Firewall option.

Well, yes, that would stop the alert but it’s only hiding the problem. If Security Centre is looking for the wrong file then surely that needs to be addressed? Shouldn’t it be looking at the “firewall” rather than the GUI? I presume the “firewall” can be identified as an executable (a service or a process).


The firewall IS running and you ARE protected. The drivers and services are started at bootup and are active before the Window GUI appears, let alone before the firewalls GUI is loaded and acknowledged by the Security Centre (which uses WMI - Windows Management Instrumentation). It’s annoying, but a common complaint and not restricted to Comodo.

Ewen :slight_smile:

Why don’t you just disable the security-center altogether ?
it’s just using resources and it does absolutely NOTHING to enhance your security :

Disabling The Security Center
To disable the Windows XP Security Center open the Services MMC:
Press the Windows and R keys > in the resulting window type services.msc > in the resulting window scroll down to Security Center and double-click on it > In the “Startup type:” box use the arrow to scroll down to choose “Disabled” click Apply and reboot, or, click Apply and click the button that says Stop.