Windows security centre [Resolved]

I’ve just downloaded comodo firewall earlier today but realized that my windows security center doesn’t recognize it. checked the forums for solutions but i can’t understand them (my computing knowledge isn’t very good). i was wondering if anyone knows of a simple solution.

any help will be much appreciated.

Hey J J, welcome to the forums!

When you say you don’t understand what you’ve read on the forums, I presume that you’ve seen the entries about rebuilding the Repository… :wink: It doesn’t have to be scary, but you may not have to go that far, either!

This has worked for me…

Go to the Security Center (Start/Control Panel/Security Center). Go down to the bottom, under “Manage Security Settings for…” and select Windows Firewall. Make sure it’s set to “Off.” Click “OK.” Reboot your computer. Going through those steps (even if Windows FW is already off) seems to reset it on mine.

If that doesn’t work, we can walk you through rebuilding the Repository in simple, easy steps. :slight_smile:


First of all thanks for the quick reply. I tried what you suggested but it didn’t work.

Okay then, step 2:

Go to Start, then Run

In the Run window, type “services.msc” (without the quotes…)

Scroll down to the Security Center entry.

Right-click the SC entry, choose Stop. Wait a few seconds, then close the window and reboot your computer.

See if that fixes it. (if it doesn’t, one of the Moderators has created a batch file you can download and run to automatically rebuild the Repository, so it won’t be very difficult)


That didn’t work either.

OH, what a bucket of monkeys! It’s just not cooperating, is it? (:AGY)

Okay then… Go to this post:,2479.msg19751.html#msg19751 This is a post from Ewen, where he has attached a Zip file. The Zipped attachment is a batch file that will automatically go through, clear out the windows Security Center Repository, and rebuild it. That way you don’t have to get your hands dirty digging around in there… :wink:

So, download the attachment, then extract the .bat file (right-click, select “Extract all”, and follow the prompts).

I’d close any open applications, then run the batch file. When it’s finished, reboot your computer. That should do the trick. It better! When it does work, this is for you… :■■■■


yes this time it worked. what a relief. thanks for the help.

Yata! Woohoo! :BNC :BNC :BNC :BNC :BNC :BNC

Boy, aren’t all those bouncies annoying? ;D

Great, I’m glad it worked. Glad I could help.

I’ll go ahead and mark this topic resolved and close it out, so that other users will know when they see it, that there’s a solution… :wink: