Windows Professional x64 Edtion and Comodo Firewall

Hi can you help?

When I try to install this on o/s comodo firewall is complaining that the version I’m trying to install isn’t compatible with my operating system?

any help?

Thanks

Rob

Rob, from your title I guess you have XP 64-bit. If true, then you should be installing this version: http://download.comodo.com/cfp/download/setups/CFP_Setup_3.0.25.378_XP_Vista_x64.exe

Just to confirm the operating system is Windows XP Professional X64 Edition.

Thanks

yw

Let us know the result of that setup file.