Windows Network - ' See Full Map '

I am having trouble with seeing the network map.
I get the following error :
’ Windows cannot create the network map. Responses from other devices on the network are delayed or there is an incompatible router on the network. ’

Without Comodo installed, I see the network fine.
With Comodo installed but disabled, I still cannot map the network.

Also, if you can see the network, did you do anything special with your settings?
I have windows 7 and my gateway router is a Linksys WRT600N (and there are no newer firmware updates for the router)

I played a bit with it here on Win 7. It won’t draw the map even when I disable the Firewall temporarily.

The Windows Help gave the following:

[quote]This can occur for the following reasons:

A computer or device on the network restarted during the mapping process. To fix this problem, wait for the computer or device to finish starting, and then refresh the network map by pressing F5.

Your computer is connected to a wireless network and the wireless signal quality is poor or intermittent. To fix this problem, move your computer closer to the wireless router or access point.

A device on the network, such as a hub or switch, is not working properly or is not compatible with the Link Layer Topology Discovery (LLTD) protocol, which Windows uses to create the map. To fix this problem, disable the device, turn it off, or remove it from your network.

Responses from other devices on the network are delayed or there is an incompatible router on the network. If responses are delayed, try waiting a few minutes and then refreshing the network map by pressing F5. If a router is incompatible, try disabling the router, turning it off, or removing it from your network.[quote]

Odd thing is I have seen the map with Vista in the past. I see no alerts of blocked traffic in the logs. Odd. ???

Anybody know of a solution for this in Win7-64 and Win7-32 ??

Upto now I must have tried everything (I guess).

  • LAN network zone 192.168.0.x is trusted zone and open for system and all apps on both pc’s.
  • router assigns IP in range 192.168.0.x correctly to all connected
  • Both pc’s have comodo CIS 4.1.150349.920 installed
  • win7-64 connected to DLink DIR635 revB1, FW 2.33EU (router WAN is connected to modem)
  • win7-32 connected to router via switch DLink DES1008D rev G2
  • windows firewall disabled on all pc’s

Weirdest thing:

  1. Cannot create network map on my win7-64 (win7-32 switched off)
  2. Switched on win7-32 => none of both could create the network map, file sharing etc works fine
  3. Disabled comodo on win7-32 => same as 2
  4. exited comodo on win7-32 => same as 2
  5. exited comodo on win7-64 => same as 2
  6. uninstalled comodo on win7-32, restarted win7-32 => BOTH pc’s CAN create network map
  7. reinstalled comodo on win7-32 and configured trusted zone => no network map on both pc’s
    8 ) still file sharing etc works fine
  8. switched off win7-32 => no creation of network map on win7-64
  9. on winvista-64 and winvista-32 network mapping was no prob

I did notice too that disabling the firewall does NOT always really disable the firewall, even exiting comodo does NOT stop the firewall behaviour of comodo => some comodo service that keeps running with “old” settings? Only solution: uninstall comodo.


Only solution upto now (win7-64 with comodo 5.3.181415.1237):

  • Go to “network and sharing center”
  • Select “Local Area Connection”
  • Select “properties”
  • unselect “comodo internet security firewall driver”

No reboot required

Just disabling the firewall doesn’t solve the problem, it seems to be the driver preventing us to see the full network map, it prevents LLTD to work >:( .


Same problem… same version of CIS like in previous post [latest for now] my windows are clean install of W7 Home Premium with SP1 and W7 Professional with SP1 both x64

disabling firewall driver in connection properties is not a solution because this is just like disabling firewall at all… :-\ however for temporary short time map check only maybe…

Same issue here. Win7 64 Ultimate. Contemplating reverting to older version of CIS Firewall. Its either that, or creating a multitude of mapped drives…

I can only see mapped drives and the local machine under “Network” when using Windows Explorer. After I connect to another machine, it shows up in the list, but the list no longer updates. In other words, if I have 3 networked computers, I have to generate 3 Explorer windows to view their contents (unless, again, I have already set up mapped drives).

I thought my router and/or OS was messing up until I came across this forum thread.

Hi jmiddletn, welcome to the forums.

Is there anything in CIS firewall event logs concerning local traffic? Also, are you saying that this was working previously with an earlier version of CIS? Thanks.

for me network in windows explorer works perfectly fine… always see all other computers when choose “network” from left pane of explorer window… but “see full map” problem still occurs :-\


I can get this to work, but the behaviour is a little strange. It seems to me the Network map is cached, once it’s been drawn at least once. Working thorough the dependencies, this is what I’ve found:

  1. The Link-Layer Topology Discovery Mapper service must be running
  2. File and printer sharing needs to be enabled and must not be blocked in the firewall
  3. Network Discovery must be enabled
  4. RPC/DCOM (TCP port 135) must not be blocked
  5. UPnP (UDP port 1900 - must be allowed both in and out
  6. Svchost must be allowed to connect and receive on all Network Discovery ports
  7. Svchost must be allowed to connect and receive over UPnP
  8. Svchost must be allowed to connect on TCP port 5431
  9. If you have XP machines, you need to install the LLTD Responder

Hope this helps

  1. checked
  2. checked
  3. checked
  4. -…- 8 ) no meaning if firewall is temporary disabled via right click on the tray icon…
  5. not applicable have win7

:confused: still can’t see network map without disabling firewall in connection properties

Same problem here. I have Windows 7 64bit, since a week. I tried to uninstall Comodo, and that solved the problem, but since have installed it again. Deactivating the Firewall hasnt helped.

Message same “Windows cannot create the network map. Responses from other devices on the network are delayed or there is an incompatible router on the network.”

anyone find a cure for this ? please