Windows Installer and system broken after update to V4 (guess i had prevV4, X32)

I hope this helps you to fix this. I cannot install the new version or my computer goes crazy.

The story is quite long, and my english not very good, so i will be very happy if you can follow the plot. :smiley:

I finally found out that Comodo was responsible for breaking Windows Installer and many registry entries so i come here thinking you should be warned about this.

I had this update that showed up (new V4!), but i don´t have any idea of which version i had before (3… or 4?), because i had to restore the system twice to where it was and Comodo now shows “windows style” windows and alerts, all changed as a mixture of windows / previous Comodo Style, and doesn´t show the version anymore when i see the About… window. (another bug?, guess not).

When i downloaded cfw_installer_x86.exe two days ago i tried to install it (day before had installed a game, so it should have worked) but it failed saying it couldn´t find Windows Installer, or it was busy…
and some hours after that i tried to install some windows updates. Then all of them failed!, NVidia removed my drivers and as it couldn´t install the new drivers left my system all ■■■■■■■ up, 400x600 and no drivers.

I tried to install many other things and they failed too. So it all started when COMODO was removed before installing the new version (if it needs it) or during it´s installation over the last version.

I restored the system, and tried to install things, and the windows updates worked. So i tried to install Comodo downloading it again, and same thing happened, and after that all installations failed.

So I investigated a bit and found out about this tool: ProcessMonitor, that shows everything a process does. So i filtered “msiexec.exe” which is basically what Windows Installer is, and executed COMODO file again. I found what you can see in LOGFILE.JPG down the attachments.

As you can see, registry options inside:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options
Cannot be read. But not even read, they simply dissapeared since then, and i guess all the other problems related to this, but sound really really bad. Not just READ access denied.

And more things: then suddenly everything goes wrong. Even entering Start menu, it shows a popup saying that there’s not enough space to show all the content of the menu… despite of having 20 free GB…

That´s all. I cannot install Comodo new version, i´m quite frightened, and if i don´t get a response or help, i´ll have to change my Firewall program. That´s a real pity.

Thanks for all.

[attachment deleted by admin]

Here’s the new style. I have window colors turned gray in windows, but this mixture never happened, and the style, doesn´t look like very good.
I guess this happens when you restore windows. Just wondering…

[attachment deleted by admin]