Windows Firewall re-enabled after each login

Lately, Windows Firewall has been re-enabling itself whenever I restart my system. I disable it each time, but it always comes back. Any solution to this? I understand it’s not ideal to be running both Comodo Firewall and Windows Firewall at the same time.

EDIT:
I think I got it working after running this in PowerShell:

Set-NetFirewallProfile -Profile Domain,Public,Private -Enabled False
Stop-Service MpsSvc
Set-Service MpsSvc -StartupType Disabled

You shouldn’t disable the firewall service especially if you’re using windows 10. As long as you have disabled the firewall for each profile with the firewall control panel you should be fine.