Windows Firewall not disabled on W10 1511 [M1790]

Windows Firewall is (re?) enabled on W10 in the 1511 update.
Can you reproduce the problem & if so how reliably?:
Been in both setups I use Comodo in
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: have Comodo running (pre-4792 version)
2: have Windows firewall disabled
3: update to W10 1511

Fresh Install
1: install W10 1511 fresh
2: install Comodo (was 4703 when installed)

One or two sentences explaining what actually happened:
In the Fresh install Windows Firewall stays enabled. In the updated 1511 case, windows Firewall was re-enabled (probably due to the settings reset issues in the 1511 update).

Windows Defender stayed disabled.
One or two sentences explaining what you expected to happen:
I expected Windows Firewall to stay disabled
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
Manually disabling the firework works fine.

Exact CIS version & configuration: updated to after 1511 installation/update
Proactive Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Proactive Security defaults

Have you made any other changes to the default config? (egs here.):
nothing other than custom rules to get various programs working correctiony.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Only from earlier versions of CIS 8 (the updated computer, the fresh install computer was a fresh install to 4703).
if so, have you tried a a a clean reinstall - if not please do?:
I’m not spending the hour needed to retrain all of the open source apps Comodo constantly chokes on.
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
using standard config
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
W10 (RTM and 1511), 64-bit. UAC on. Admin local accounts.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
only W10 Defender/Firewall

Attached Files: Killswitch is not installed

[attachment deleted by admin]


Please check this issue again with version <>.


I can confirm that the built-in Windows firewall does not get disabled/turned off after installing CIS Moving to Verified

Then you have to turn it off manually by going into the control panel. Then to Windows Firewall. You will have the option to turn on or off Windows Firewall.

From Comodo: CIS disabled Window FW only on WIn 7 and and lower. According to requirement from Microsoft, CIS does not has the right to turn off their components beginning with Windows 8.

So users would need to manually turn off the windows firewall if they should choose to. Note this applies to the Windows Firewall control panel applet, do not disable the windows firewall service. Moving to resolved.

this bug is STILL present…

Please read the posts, this is not a bug, but by design, a design dictated by Microsoft.
This includes you, LordRaiden!