Windows Firewall not disabled on install [Merged Threads]

I just installed CIS and I was surprised to see that the Windows Firewall was still running after the installation completed. Any reason why it’s not disabled? If for whatever reason it’s not OK for CIS to just silently disable Windows Firewall, maybe the user should be asked during installation if the Windows Firewall should be disabled … Most other firewalls I tried attempt to disable the Windows Firewall.

How did you check that Windows Firewall is not disabled?

It was the same for me: I uninstalled CFP, rebooted and installed CIS firewall/D+ only. When I started a program (don’t remember which one, but I think one that communicated to a backend via localhost) a Windows firewall popup asked if it should be blocked. Additionally there was a CIS alert.

PS: The program was probably the Maxima CAS: http://maxima.sourceforge.net/

Looked the Windows Firewall settings in the Security Center … Simple. Yeah, I went ahead and disabled the Windows Firewall, but CIS should have done that for me.

Well, simple and half of the time broken because of buggy WMI so what security center shows doesn’t match reality.

Same thing here, windows firewall not disabled.

Hi Guys,

In the past I was reporting a bit different problem regarding Windows Firewall (WF) but there is similarity, which is:

It seems that Comodo does not check whether WF is active but that should be done periodically.

What I found that MS can silently activate WF. It happened several times here. One of the cases was when applying SP3. WF was set back “ON” by that.
In a few occasions that occurred when I was changing some network settings.

So, it looks like that wasn’t fixed.

***Edit: to be honest i will add that I may not state that for sure because I worked with CIS for 8-10 hours only.

At the same time I did not experienced any changes regarding WF. Uninstall CFP v3.0.xxx and installation of CIS 3.5.xxx went smooth and I checked that WF remained disabled (it is a habit now because Comodo will not do that checkup :wink: ).

Now, as I reported in one of the threads here I am back to CFP version 3.0.25.378.
WF was and remains disabled during and after downgrade too.

It should be something specific in your environments but unfortunately in all posts there is no mentioning even OS. Probably it may help developers if you do.

My regards.

But to be clear: The internal Windows firewall should be disabled when CIS is installed, right? Or not?

Hi,
Windows Security Integration is working fine for me. Please verify the issue after clearing the repostitory folder. Do the following to clear the repository

  1. Click start-> Run->Type ‘cmd’ ->hit ‘ok’.
  2. In the cmd window, write NET STOP WINMGMT /Y and hit Enter.
  3. Now Type cd "%windir%\system32\wbem" hit Enter.
  4. Type RD /S /Q “Repository” and hit Enter.
  5. Last of all, write NET START WINMGMT /Y and hit Enter.
  6. Close the cmd window.
    7.Restart the system

OS:WinXPx32 SP2
No other Security s/w

Regards,
Vicky.

Looks like the alert for disabling 3rd party firewalls manually disappeared ?

Windows XP SP3
CIS_Setup_3.5.53896.424_XP_Vista_x32.exe
No other security software running
Reproducible yes; uninstall reboot, activate windows firewall, reinstall it doesn’t prompt anymore.

There has been a warning for this during install, it’s not recommended to run 2 firewalls on the same system so yes you should manually disable the windows firewall.

Yes, it’s recommended to have Windows Firewall disabled if you’re using a 3rd party firewall.

LA

I’m a little inconfident about the following issue.

After installing CIS, Windows XP reports that the firewall is running and that it recognizes CIS. So I like that.
The problem is that CPU activity rises to 100% percent frequently when starting programs that seek contact to the Internet this leads to the computer being inresponsive for a few seconds.

I now realized that in Windows XP Security Centre there’s another option at the bottom to manage Windows Firewall. When clicking there a new window is opened. On the tab “advanced” in the most upper space I see the name of my connection with a “v” in front of it. There’s a text above it which states that the Windows XP firewall is active for the mentioned connections. So apparently this means that despite the presence of CIS, the Windows XP Firewall is still active on this connection (meaning 2 different firewalls are monitoring the connection, which can’t be good).
When I remove the “v” the connection is indeed significantly faster, but the problem is that I don’t get any warnings from CIS about certain to or from the Internet. This worries me very much.

Do I need to place the “v” again or is CIS indeed monitoring the connection and isn’t security compromised?

I can’t find any specific information in the KB, so I would be very grateful if someone has an answer.

You must disable Windows Firewall. Dupe of this bug.

Merged Threads. (:m*)

Josh

Windows Vista 32-bit. I have been running Comodo Firewall in conjunction with Windows Firewall for an year now, ever since it was 3.0.10 beta. Across the versions over the months and having went through a SP1 update I haven’t ONCE had trouble with WF and CFP conflicting. Are you all sure it’s worth the hassle?

I’ve found a webpage which contains interesting information in relation to the Windows Firewall issue.
Please take a look here:

http://www.instant-registry-fixes.org/how-to-remove-firewall-included-in-windows-xp/

I suggest not to remove the Windows Firewall as described on that page but only to disable the mentioned service.
Maybe the developers can use this information too, in order to improve the installer.
So far I haven’t seen any negative effects on the performance of CIS after using this tweak.

I don’t think they will build in the “disable” firewall option because there are way to much firewall’s out there to do that. And on the other hand, I don’t like software that would disable my firewall.

What has gone wrong is that in the 3.0.x version you would get a warning that you had to disable 3rd party firewall’s manualy, that has disappeard, it should come back in the next release.

The warning is still there but moved in component choose page of installer, as now you can select not to install firewall.

dchernyakov,

Have i looked over that :slight_smile:
But for my opinion my guess is that 99,9% did not read that, I hate popups but i’d say please bring the old “alert” back or make it more clear to the “next, next, finish” user that you should uninstall your 3rd party firewall.

Anyway thanks for the feedback.

[attachment deleted by admin]

What’s wrong with a clear screen during install: “Comodo has detected that Windows Firewall is active. Would you like to disable it?”

Sure, users may have other firewalls installed that Comodo should not try and detect/disable, but Windows Firewall is everywhere and many times enabled.