Windows firewall keeps switching itself on!?

I have the problem that the Windows firewall keeps switching itself on. I keep turning it off all the time, but it just won’t take no for an answer.

Every time I start my computer the Windows firewall is on, as well as the Comodo firewall.

The Windows security center reports that both firewalls are on (so note that, in particular, it recognizes Comodo), so I turn off the Windows firewall. This I have to do after every reboot.

Also, as soon as I switch from cable Internet connection to wireless connection, the Windows firewall silently turns itself on again. This is beginning to get a major pain, since it screws up my wireless connection to have two firewalls running at the same time.

Again, turning the Windows firewall off manually works just fine — or so the system says — but when there is a change of connection status from cable to wireless the firewall is turned on again.

I have spent quite some time now trying to solve this problem, but I have not found any solution.

I am running Comodo Internet Security 3.13.120417.573 on 64-bit Vista Business SP 2 on a Lenovo X200.

Any help would be very much appreciated.

Please go to start and search for services.msc and start it, maybe administrative rights are requiered.

There you go to Windows Firewall ->right click → settings → starttype manuell or deactivate, and stop the service and everything should be fine.

Not meaning to ■■■■ in on someone else’s thread, but I have this problem as well. I did as you explained in the post above but the only entry I can see in Services mentioning Windows Firewall is for Windows Firewall/Internet Connection Sharing (ICS), which says that the status is Started, Automatic, Local System. Is it this entry you mean should be switched off?.
My OS is Windows XP Home SP3.

Thanks. I tried your suggestion and so far it seems to work just fine. My problems with the wireless are gone now. I guess this still leaves the question open why you would need to use a big administrative hammer to make this work. Why doesn’t the Windows firewall accept just being turned off via the Security center? Seems kind of meaningless to have the option there if the system doesn’t respect it anyway…

I think there is a difference between XP and Vista here. The instructions given by Adioz86 worked for me on Vista, but I have no idea what things look like in XP. Based on some googling I did before posting my question, I believe that in XP you indeed have to fiddle with the settings for “Windows Firewall/Internet Connection Sharing” but I don’t know this for sure and I don’t remember what the suggested settings were. Perhaps a search on Google or this forum can help?

maybe it’s caused by the point, that windows firewall turns on, if windows firewall is enabled for a network adapter, and if this adapter starts working, windows firewall starts itself. But i don’t know, if it’s really like this. but this would explain my experience and yours, too.