Windows Firewall Keeps Staying On

I’m using Commodo as a Firewall, so I went to the Security Center for Windows Service Pack 2, and put a dot in the place that says turn the Windows Firewall off. I don’t want two firewalls running on my computer. However, every time I reboot, I’m back with the two Firewalls running. (:SAD) Is there a way to shut off the Windows Firewall, so it will stay off through a reboot, and will only come back on if I take a specific action to bring it back on. I’m using version 1.1.1.6 of Commodo. I had used Commodo some months ago – perhaps an earlier version – and then stopped using it. I don’t remember having this problem then. Has Commodo changed, or has there been some update of Windows that makes me have to go through the nuisance step of continuously having to shut off the Windows Firewall. I want that firewall as a backup, and easy to start-up, but as long as I’m using Commodo, I don’t want the Windows Firewall active every time I reboot the computer.

You should first install a newer version of the firewall.
Do you have Launchpad installed?
The version no seems to belong to it.
If you uninstall your old version, and install a newer version, it shouldn’t be a problem. Download it here.

If you still have problems, you can turn off the XP firewall service.
Go to control panel/administrative tools/services and double click the “Windows firewall/ICS” service and turn it off, and put it to disabled.
Let us know how it goes.

I have recently installed Comodo Firewall Pro 2.4.18.184 and have had a similar problem to that posted by AOwl. I went to Control Panel/Administrative Tools/Services and disabled Windows Firewall and saw in the same services screen that Comodo was on automatic start, but when I had a look in the Windows Security Centre it said I had no firewall and that Comodo was switched off. So I went to my desktop shortcut, double clicked to open Comodo and then had another look in the Windows Security Centre, which now tells me that the Comodo Firewall is up.
So it seems that Comodo isn’t automatically start up when I reboot, despite the services dialogue box suggesting it should.
What am I doing wrong?

Hi,

What I do to see what’s actually going on is go offline, go to services.msc. Go to Windows Management Instrumentation & stop the service. It will also stop Security Center service. Leave them set to automatic. Next go to C:\Windows\system32\wbem\repository. Delete the folder “repository” & reboot.

Now Windows Security Center will show you accurate FW/AV. It’s not Comodo it’s a Windows thing!

Michele

Thanks Michele.
But are you sure my problem is to do with Windows rather than Comodo? I know the title of this string suggests that and that I posted under this string, but in my case, Windows Firewall stays off, but Comodo doesn’t seem to start up when I start my computer - even though it is set to do so under Amin/…Services.
I noticed in one of the other posts (https://forums.comodo.com/index.php/topic,6925.msg50675.html#msg50675) that there is a problem with CFP looking like it is still initializing when it is actually already loaded, and that there is a solution to this in the coming V3, and perhaps my problem is related to this.
Tschüß
ChickyChris

Wonder if one of these applies?
https://forums.comodo.com/index.php/topic,7557.0.html
https://forums.comodo.com/index.php/topic,7633.0.html
https://forums.comodo.com/index.php/topic,7780.0.html

but when I had a look in the Windows Security Centre it said I had no firewall and that Comodo was switched off

If you really want to use the Security Center service to ‘check’ whether or not Comodo firewall is on, first make sure to delete all references to old uninstalled firewalls like this (courtesy ‘dooplex’):-

1 ) Start → Run → wbemtest (ok)

2 ) In wbemtest click Connect…

3 ) Where it says ‘root\default’ overtype with: root\SecurityCenter click Connect

4 ) You see a grid of buttons, click Query…

5 ) In the query box type: “Select * from AntivirusProduct” and then ‘Apply’. If you get a result you can double click it and scroll down the properties of that AntivirusProduct.

6 ) You can also run the query: “Select * From FirewallProduct” if you have another firewall product (which is WMI enabled) apart from Microsoft’s (which is perhaps surfaced in the root\CIMV2 namespace and not in the SecurityCenter namespace)

7 ) Check that the entry is indeed the unwanted Firewall product (e.g. Sunbelt Kerio) by double-clicking on it and checking things like the company name. Once satisfied, delete the entire entry.

8 ) Log off and back on again. Alternatively, reboot.

If the firewall is loaded in system tray, it’s functioning properly whether or not it says ‘initializing’.
To get rid of the ‘initialising’ message, open Comodo, click on ‘Custom’ slider without changing anything, then close Comodo. Check the balloon message.


PS. Attn. Moderators: Can't we have a 'quick quote' button - so that not the entire post is quoted in the forums ? Am I missing a trick ? ;D
PS. Attn. Moderators: Can't we have a 'quick quote' button - so that not the entire post is quoted in the forums ? Am I missing a trick ?
There's the https://forums.comodo.com/Themes/NewComodo/images/bbc/quote.gif regular quote option, but you still have to manually copy and paste.

Thanks, I see. But would be nice to just copy a paragraph** and click ‘quick quote’
like in Opera forums. Definitely not a train smash. ;D

** I mean highlight.

What a coincidence. My previous post just now was about forum suggestions.

Chris,

No I’m not sure! Just a civilian here! :slight_smile: Have you been able to resolve your issue? Ocky’s post is certainly impressive! I hope you have.

Michele