Windows Explorer disabled by CCE

Hi,

Some days ago I ran Comodo Cleaning Essentials on my computer, and it disabled my Windows Explorer, so explorer.exe is now NOT running. The file is still on the system, it was not quarantined, and if I try to run it manually from the Task Manager, I get the following Comodo Defense Alert saying:

“ntvdm.exe is an unsafe application and it is about to modify C:/Windows/Temp/scs352.tmp”

Even if I allow it, Explorer won’t run. There was no restoration point available for me to roll back. What Can I do to solve this? Thanks!

Step 1: Make some coffee and order some pizza
Step 2: Drink coffee and eat pizza
Step 3: Download Linux Mint
Step 4: Burn linux mint to a cd/dvd
Step 5: boot from cd/dvd and from there try to go to c:\windows\system32\dllcache
Step 6: If you find there explorer.exe, copy it to c:\windows
Step 7: restart without cd and see if the problem is solved.
Step 8: if the problem persist, write back here so we can try something else.

@Comodo: Guise, you NEED to make something like www.reimage.com
With BOOTCD capability, for stuff like this. Hear me out bros!

Try running system file checker from the command prompt to have Windows check its system file integrity: How To Use Sfc.exe To Repair System Files - Microsoft Windows Mini-Guides .