Windows 8.1 x64, CIS 6.x, BSOD issue

Hi there,

I am having issues installing CIS 6.latest version on different computers using windows 8.1 x64

XMG A522. CIS ran pretty good under windows 8, so I decided to upgrade to windows 8.1. What I did not do was a backup and setting a system restore point. Needless to say what happened after the upgrade.
Windows crashed with BSOD (blue screen of death) telling me something like “driver power state failure” tried to install CIS on a clean system again and again without any success. The computer either froze or shut down by the above BSOD.
This was in October 2013. I decided to run without CIS, because I thought it either is a windows or CIS bug and someone is going to fix it soon. I also contacted the manufacturer for a Bios update, they told me “planned but no release date yet”.

Every now end then I downloaded the latest CIS, created a restore point and gave it a chance. Now, we are having January 2014 no success so far. I always failed on a frozen computer and thought “well…a Bios issue”… until yesterday.

Gigabyte P25K (i5 Version)
New computer, clean windows 8.1. Direct installation, no upgrade or update.
First installation has been CIS downloaded January 15, 2014. I was kind of lucky being able to download the latest data base but my computer suddenly froze.
I do not even have a clue what causes these issues.

Frankly speaking I am sick and tired of installing and restoring again and again.
Tried to find answers for weeks, obviously using the wrong keywords.

I’d appreciate if anyone could help me to find a work around or solution.

I’d also appreciate if COMODO would suffix the installer with the version. I have way too much cispremium_installer(i).
Creating a system restore point before installing or at least asking for it would be a HUGE PLUS as well.

Thanks in advance for your useful help…
Please let me know if I missed important information.