Windows 8.1 X64 BSOD - ntoskrnl.exe

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    I get a BSOD 2 minutes +/- after the computer was turned on.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Install Comodo Firewall V7 7.0.315459.4132
    3:BSOD after 2/3 minutes.
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
    Isn’t any software.
  • Any software except CIS/OS involved? If so - name, & exact version:
    Eset and nothing more is starting with the PC.
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I will copy & paste the information I posted on other topic:
    "Some days ago I updated to comodo v7, days after that I got a strange BSOD. Today I got 5 BSOD. Seconds before the BSOD, the comodo tray icon changed to the red X.

Then I uninstalled comodo and surprise, no more BSOD!

I had the most recent version of comodo (updated some days ago)

Windows 8.1 Update 1 x64 on a recent machine.

(The first BSOD happened before the Windows Update 1 with the same bug check code and driver! I restored the system and everything was fine. On April 8 I updated to 8.1 update 1, and no problems, but then after some days (today) it gone crazy giving me a BSOD all the time.)

More information:

Caused by driver: ntoskrnl.exe
Bug Check Code: 0xc000021a

Note: I only use comodo firewall, with everything disabled, everything! HIPS, and all the other options are disabled, only firewall was active with custom rullset."

[ol]- Exact CIS version & configuration:
7.0.315459.4132, Only Firewall

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Everything was disabled, HIPS, Sandbox, Web filter, etc. Only thing on was the Firewall.
  • Have U made any other changes to the default config? (egs here.):
    No need, I got BSOD even with the default config.
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    Fresh install from CFW 6 to CFW 7 using revo uninstaller to clean everything.
    [li]if so, have U tried a a clean reinstall - if not please do?:

[/li]- Have U imported a config from a previous version of CIS:
[li]if so, have U tried a standard config - if not please do:

[/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 Update 1 x64, UAC disabled, Account = Administrator.

  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=ESET b=Nothing

[ol]I don’t want to post a memory dump because of privacy concerns. I know that maybe this is the only way to get the problem fixed, but…[/ol]

Please follow these steps to create and attach a necessary file:

  1. Please first configure your computer so that it will create a Complete Memory Dump. Instructions on how to do that are given here.

  2. Then replicate the BSOD.

  3. After the computer restarts navigate to the newly created Complete Memory Dump (it will be huge) and upload it to a file sharing site. The best one I have found is Mega (found here). It will require you to create a Free Account to share the download link (once it finishes uploading), but I believe it is worth it. [note that if need be this uploading part can be done while the computer is running with a different version)

  4. Once it is uploaded (which may take a very long time), you can respond to this post and paste the download link for the dump.

Thank you.

I don’t want to post a memory dump because of privacy concerns.

Anyway, I know that Im not the only one with this BSOD, since one friend of mine, is with the exact same problem. I tried the V6, but V6 doesn’t work on update 1.

If you are worried about publicly posting the memory dump you can always just send me a PM with the download link. I can then pass this directly to the devs without posting it publicly. However, the memory dump is needed for the devs to fix this.


As mentioned previously, the Complete Memory Dump is the only way to get this fixed by the devs. Please upload this to a suitable File Sharing Site, such as Mega, and provide me with the download link via PM. This will never be posted in the forum and will be passed directly to the devs. Also, Mega in particular has very strong encryption. Thus, the dump should be absolutely safe.

Let me know if you have any questions, or if there is anything I can do to help.


AutoKMS.exe was the problem, removed it and no more BSOD.

Thanks for letting me know about this. In that case I will move this bug report to Resolved.

Thanks again.