Windows 8.1 Tablet Won't Share Windows 7 Drive


I am having problems with file/drive sharing in my workgroup. I have a Windows 7 (Home Premium, SP2, x64) Desktop and a Windows 8.1 (8.1.2, Pro, x64) Tablet. I am able to share a Tablet Drive (Win8) on the Desktop (Win7) but I cannot share a Desktop (Win7) Drive on the Tablet (Win7). It has occurred to me that perhaps my problem lies in the firewall. I use Comodo CIS (version 7.0.317799.4142) on both machines, but is there a setting in the firewall (or elsewhere in CIS) that could be stopping this?

On the Windows 8 Tablet explorer, I can click on Network and see the Desktop machine; however, when I click on the name of the machine, I get a message from Windows 8 that I don’t have permission to open it. However, I have set all of the permissions exactly the same on both machines.

Thank you very much for your help.


I would restart both device and machine, attempt to connect, then check the view logs option / firewall log for both, and see if the firewall is blocking ip connection attempts from either of the clients.

I tried all of that - there were no alerts on either machine! I am really stuck here!


Typically for me, if comodo firewall is the culprit preventing clients from accessing each other, I won’t even be able to see the other client in the network area of the (view computers and devices) tab unless I have first accepted the ip connection attempt alert on the client I am attempting to connect to. I wonder if somehow this alert was not answered in time or missed all together, preventing the communication.

Provided you have a global rule already established to allow incoming network trafic, one thing you can try is this…

On the client you are attempting to connect to, under advanced firewall settings, go to application rules, click the plus box in front of (system) to expand the rukes there. Check to make sure there is not a (block) rule there. If not, for testing purposes, double click (system), the appkication rule box should pop up, click the arrow at the bottom of the box, and click the (add) button. Next, create the following rule/ Action = Ask - Protocol = IP - Direction = In / Set Source Address, Destination Address, and IP Details to Any, click OK.

Now the rule should be shown in the established application rules box, make sure that this Ask rule is the topmost rule there, if not, you can move the rule up by clicking the tab at the bottom, when this is done, click OK again to close the box, and click OK again in the advanced settings interface to save the rule. You may want to restart both clients again.

What this rule will do is create an alert on that machine when ever another client attempts to connect to it, when this happens you can allow the connection request and click the remember my answer if you do not want to be bothered again with it. Of course you may want to go back into the settings and remove the Ask rule.

I acually prefer this setting as I am on a big shared network and like to know who’s attempting to peek at my machines. Not suggesting, but some devices and apps can get past this alert, so I created an additional rule to also Ask tcp and udp connection attemps In to also alert me.

Thank you WWWT for the careful and exact instructions! I did as instructed (I think) but I didn’t see anything that would tell me anything was happening - how does one tell?

I also did the same on the tablet but again, nothing! I am obviously missing something here, but I have never done anything with these rules so I might have missed something!


you’re welcome sparky, I’m tryin here. under advanced firewall settings, double check that the (do not show popup alerts) is unchecked. also, check the (global rules) tab, and see if there are 2 allow rules at the top for incoming and outgoing ip requests ( would have green checkmarks beside them) as these would be needed for communications between clients on the network. and again check your (system) rules in the (application rules) tab that the 2 ask rules that you created are at the top (should be in yellow).

if these rules are in place, when you fire up your desktop, then fire up your tablet, an alert should pop up on your desktop showing the tablet ip attempting to (handshake) with the desktop. If not, the popup should most certainly appear on the desktop if you were to attempt to connect to it from the tablet (network / workgroup area) the alert on the desktop would say something lke (ip of tablet) is attempting to connect to your computer, do you want to allow this connection? this is when you would choose to block or allow the connection. in this case you want to allow. BE aware of the checkbox at the bottom left hand side of this alert (as with any alert) as you can choose to remember the answer or not. this is personal preference. example, if one where to block this (ask rule) connection attempt and unknowingly have the remember answer box checked, a block rule is created and would cause connection problems in the future.