Windows 8.1 - problem with one single app

I have Windows 8.1 (Dutch version) and have a ‘metro’ app that I use to get new alerts if someone posts something new on the learning platform of our school (the app is called Smartschool Me! but can probably only be found in the Belgian Windows Store). Since the last update of Comodo Firewall (I have the free version), I always get a connection error within the app. Adding the app to trusted applications in Comodo doesn’t help. I can only connect and retrieve alerts when I completley uninstall Comodo. Other apps don’t have any problem to connect at all, only this one, but it did work correctly until the most recent update. (I also have the free version of Avast Antivirus installed, but disabling both Comodo and Avast doesn’t help, only uninstalling Comodo Firewall does …)
I have been trying for half a day to find a solution, but to no avail … Does someone know how I can solve this problem?

Update: notification do seem to come in, now, but the app has a link to take me to the website of our learning platform and login directly, but when I click that one, I get a connection error …

No one?

Same here :frowning:

  • Since the last Comodo Firewall free Win8 update
  • Modern app “Nextgen Reader” cannot connect to its data source feedly anymore
  • Solved immediately once Comodo Firewall was uninstalled
  • Deactivating Comodo doesnt help, adding the app to trusted software in Comodo settings doesnt help
  • Happened on Win 8.1 and Win 8.1 Update 1
  • Reproducible on all my Windows machines which run Comodo Firewall

So I had to uninstall Comodo and only rely on the Win8 firewall until the next Comodo version which would hopefully fix this issue.

Thanks in advance

Hi,
Once again I notice the current Comodo Firewall causing issues on systems with Avast installed.
To me it looks like they are not playing nice with each other, see if any of the advice in the link below helps.
Making other security programs work with CIS

Thanks.

I uninstalled Avast and the problem persists … The problem only started with the most recent Comodo update for me …

Thanks a lot for the hint.

On both machines I am not using Avast.
Simply un-installing Comodo solved all my recent modern apps problem (which I never had before).
Clearly a Comodo Firewall problem of the most recent version.

I have same problem after update CIS to version 7 (7.0.317799.4142).
Some Metro apps (IM+, Evernote) can’t connect to Internet anymore.
I checked firewall rules also and everything is setup Ok.
I tried disable CIS temporarily but is not working. Only complete program uninstall helped.
I’m working on Windows 8.1 with Update 1.

Also got some problems with only certain Windows 8 apps since last Comodo upgrade (I noticed Here Maps and Fitbit).
Fitbit complaoins about no Internet connection.
The most funny is Here Maps. It can get additional content like nearby reastaurants, etc, but cannot download the maps themselves.
Looked a bit with fiddler. In boith case, it is HTTPS traffic that is not behaving properly. According to Fiddler, there is traffic sent, but only headers and no content.
I also confirm that disabling Comodo does not solve the problem, but uninstalling restores the connections.

So for now, I will have to uninstal Comodo I think…

Please investigate

On CIS 7 I have the same problem with two (payed) apps:

  • Star Wars: Assault Team
  • Halo: Spartan Assault

I’m now back on CIS 6, that works.

It’s seems that problem is rather in antivirus and not in firewall.
I tried uninstall only firewall module in CIS uninstaller, that keeps antivirus module alone, but problem still persist.

Could anybody experiencing problems with Metro apps check the Firewall logs? We may find useful information there.

No records in firewall log.

I filed a ticket with Comodo support to report the issue and received a response that looked generic mentioning that the issue is due to a conflict and suggesting to test through clean boot. I uninstalled all other security programs (Avira, Malwarebytes), rebooted, reinstalled Comodo, blocked all other third-party programs and services through msconfig and rebooted

and…

… the issue is still there!

So, at least this seems to prove that the issue is with Comodo alone, no other program involved.

I will try to reopen the ticket if this is possible…

To be continued…

Hi all, I also have problems with my HERE maps app. I can’t login into my acount and seeing and downloading maps. Only stopping all COMODO services I’ve installed (Firewall, HIPS and sndbox) and killing cmdagent.exe twice from taskmanager (the first time it restart automatically) i can use it again. After restarting the COMODO services, Here Maps stop working again.

I also just noticed that killing cmdagent.exe using Comodo’s very own Killswitch program restores the app functionality. I didn’t need to disable anything else. Restarting cmdagent from the services page immediately stops HERE maps from downloading different map info.

Any update on this issue from Comodo?

That would disable the firewall and (part of)defense+ components.

Of course! This is not a solution, it just proves that Comodo agent is the culprit. I contacted Comodo support and (hopefully), they escalated the issue. For the moment, I uninstalled Comodo, which is a shame as I really liked it (while it worked)

Comodo really needs to take a look at this ASAP. >:(