Windows 7 VPN with Comodo Firewall


First of all, i’ve been using comodo firewall for like 2 years. So i know the basics.

I have a windows 7 VPN which works PERFECTLY with comodo deactivated.

With comodo on, even on training mode it also works “fine”, but I CANT connect to the internet trough the VPN. I’ve tried ALLOWING all IP, TCP/UDP and ICMP request in global rules (3 rules at top of every other). And the result its the same. Internet wont work unless i put “deactivated” on the firewall. Not even training mode

PD: The firewall its on the Server, the Client doesnt have firewall.

Any1 knows how to do it? :S

With an ssh+http proxy i had it worked fine, but i have to install extra software

PD2: Events log doesnt show ANY block/action.

Thanks ^_^.

EDIT: Reinstalling didnt help

You probably have a network zone for you VPN connection in My Network Zones. Make it a trusted zone using the Stealth Ports Wizard. Does that help?


I dont have a zone (i have auto-detect new networks ON) the server its a windows 7 PPTP VPN.

I can login and see home computers trough the VPN, but i cant connect internet (Client [at] Windows 7 says “No internet access”).

My SERVER network configuration its.

Server IP:
Server VPN IP:
Client VPN IP:

I made a new network which only has two IPs, and And no luck :frowning:

In fact if i allow ALL trafic (make 3 global rules, ALLOW all tcp/udp, ALLOW IP and ALLOW ICMP). The result its the same, which makes me guess comodo its blocking something that its not reporting.

Also i tried with everything disabled. Attack dettection settings off, tried with “This computer its a computer bridge (For example ICS server)”… no luck

I can use a SSH server with comodo enabled (openSSH) and tunnel my traffic there, so i guess its some kind of incompatibility between comodo and windows VPN. But thats not working for some DirectPlay games =).

PD: Comodo its ON on client too, and it causes no problems there :-. If i disable server’s comodo, everything works fine.