Windows 7 locked down after installing Comodo Firewall and Avira

Hello, people!

New to the forum after finally joining the Comodo bandwagon - hopefully to stay! :slight_smile:

Well, I’m running Windows 7 RC 7100 (32-bit) - and yes, I know it’s not officially supported by Comodo yet, but I also know there are a lot of you guys and girls trying it too, and may have an insight or two to give me… (Not to mention that Comodo must be listening attentively, I suppose, for eventually they will have to support it…) So far I’m loving Windows 7: it runs at least as fast as XP (often faster) on my 3-year-old single-core Athlon 64 3800+ with 2 GB RAM, and this RC is already much more stable and has much less rough edges and bugs than many RTMs Microsoft has put to market in the past (including XP, which, if you don’t remember, was a nightmare before the service packs).

I was using Kaspersky Internet Security 2009 on Windows 7, as I was on XP (which I still have in dual-boot), but once-great Kaspersky isn’t all that harasho any more. A few files uploaded to Virustotal.com and an on-line NOD32 scan made me alarmed at the rate of things Kaspersky was letting slip in. Plus, I found it very suspicious that it was reporting zero network attacks. On XP, I’m attacked all the time, Kaspersky blocks it and shows it in the log. But not on Windows 7, which made me suspect KIS’ firewall just wasn’t working at all on Win7!

Of course, getting rid of a whole security suite means replacing both the antivirus and the firewall (and maybe a few other things, but these two components are the ones that really matter). For the AV, after reading the latest reviews, I pre-selected Avira and NOD32, but the former’s price tag of 0.00 was more attractive to my currently very empty pockets… And although I had tried ZoneAlarm in the past and it wasn’t bad, its reputation was tarnished by that series of exploits in the firewall itself that it suffered some time ago. So, Comodo was the natural choice. I downloaded it yesterday, already got the brand-new 3.9.95478.509 version, installed it (only the firewall) and loved it right away. (Yes, I did uninstall Kaspersky thoroughly - including inspecting the Registry for all traces of it.) No problems either installing or making it work (actually, very, very few things aren’t working perfectly on Windows 7, in my experience).

Next I installed Avira on top of it. All went fine for about half an hour. Then everything stopped working. Even in an administrative account, any program I tried to use gave me the message: “Windows cannot access the resource. You don’t have the permissions for that.” (Not sure about the exact wording, but it was something like that.) The only thing working was the Task Manager after a Ctrl+Alt+Del, but it would only list the processes and not let me kill any of them (same message about not having permission). Then I tried to restart the system and my eyes popped as I read: “You do not have the permission to shut down the system.”

All I could do was press the hardware Reset button and start a system restore to the point before Comodo was installed. Now I have Comodo up and running again, but no antivirus (eeeeeekkkkk!!!) - well, my system had been scanned before, I trust that Comodo isn’t letting anything in by direct attacks, I’m not surfing anywhere I shouldn’t, I’m not using any instant messengers or even programs I can avoid running, I’m loading no removable media, all my e-mail comes through old-fashioned but extremely safe Pegasus Mail, so I think I can very cautiously run this risk for a short while. But not indefinitely, of course.

I should also mention that I have Spyware Doctor running as well. So, the problem is that either Comodo or Avira caused it, probably because of some incompatibility. Now, what is incompatible?

  • Avira and Comodo?
  • Comodo and Windows 7?
  • Avira and Windows 7?
  • Avira and Comodo when on Windows 7?
  • Avira and Spyware Doctor?
  • Comodo and Spyware Doctor?
  • All three together (too much security software)?
  • All four (i.e., including Windows 7) when blended together?
  • Some obscure hidden process or driver, nearly impossible to spot?

I know you won’t have an easy answer for so many variables, but maybe someone can shed some light. And yes, next I’ll be investigating Avira’s forums, too, but although the problem only happened after I installed Avira, it was so immediately after I installed Comodo that I can’t know for sure to which of them I can trace it.

Thanks a lot!

The exact same thing happened to me. I had just installed build 7229 x64, and the video card drivers were installed from windows update. I then double clicked on the CIS installer and on the avira personal installer. They both seemed to install fine, no errors. I only installed the firewall component of CIS. I rebooted and discovered that Avira wasn’t running at startup. Comodo gave a message for a long time that the firewall is being initialized.

Firefox wouldn’t run, in fact no program could start.

I then uninstalled comodo, as I couldn’t get the Avira uninstller to run. Rebooted and no problems.

Any ideas what caused that? Besides Windows 7 being unfinished, incomplete?

Certainly CIS and Windows 7 quite happily coexist, even though Windows 7 isn’t yet officially supported. I cannot vouch for Avira as I don’t use the product, but from what I understand, it is supposed to work with Windows 7, and according to this thread How Compatible CIS is With Other Security Products: Your Opinion Needed it works with CIS. Unfortunately, I cannot comment on Spyware Doctor.

A few things to check:

Make sure you have disabled Windows Firewall.
Ensure you have removed all remnants of any prior installations of CIS etc.
Install CIS with elevated privileges (this shouldn’t be necessary, it installs fine without)

Not sure if it’s relevant … nonetheless …

Exactly the same thing just happened to me on … Win XP SP3. I also had avira installed and commodo firewall came on top of it. All worked fine for about a month (avira and commodo coexisted peacefully), and I experienced the issues you described immediately after commodo updated itself.

hi all.not all things happend to me,but some.in my opinion there are incompatibilities betwen CIS & Avira,i can’t explain what kind of incombatibilities,but i was forced to reinstall XP,now i’m using the entire CIS suite,with BOClean included (wich is working in background).since then no problem.hope is useful.

BOClean is now part of CIS, so you may feel quite safe removing this from your system.

This is what you get for using a beta OS. Dont blame CIS or Avira.