Windows 7 firewall - yay or nay?


First - I know that running multiple firewalls at the same time is not recommended. Which is why I’m writing these lines. As we all know, Comodo installer does not disable Windows Firewall by itself so one has to do it manually. How far should I go in disabling it? I turn off Win Fw through the Control Panel (which enables file sharing and network discovery but Comodo protects that by stealthing ports, right?). But when I choose advanced settings on the panel to left I see that Domain Profile is still active. Should that profile be disabled as well? Does Comodo protect that area? These are my concerns for now.


your Windows account is probably not associated with a domain, so it doesn’t matter. And yes you can turn off Windows firewall completely if you run a third party firewall. The only restriction was that if you did that on Vista, IPsec (encryption for VPN) was turned off too. Not the case anymore in Win7, Ipsec remains available if you turn the firewall off, so just don’t hesitate anymore, you don’t need two firewalls :wink:

Thanks for the reply. The weird part now is that Windows adds unknown computers to my network places. Is there a way to prevent that? Maybe disabling inbound monitoring only without disabling whole Windows Firewall would be a better choice?

yeah that’s really weird. I wonder how it can add any “unknown” computers when you should only see your system, your router, and other “known from you” systems on your LAN. You might be connected to a public hotspot in your neighborhood. Can happen because you deactivated the “public” protection in Windows firewall, which has to be done anyway if you run Comodo >>> you now have to set your trusted zones with Comodo >>> see the stealth port wizard in the firewall (Comodo) basic features, this should solve your problem once completed.

ps: check also your connections in Network and Sharing center, and make sure you’re connected to your own router and nothing else.

I don’t have a router at home. Since the Network Discovery is on after disabling Windows firewall it automatically add those machines (which I can’t access but I’m afraid they can). I tried to rewrite some of the rules from Windows firewall to Comodo but I see same results. I have even disabled File and Printer sharing on Microsoft networks in my network adapter settings. My network interface is set to ‘Public’ and it still finds those computers.

okay but you shouldn’t see other machines that don’t belong to a network you’re connected to. How are you connected by the way? you must be connected to a public network. Doesn’t matter if you disable sharing (which is actually more then advised in your case), you’ll still see the computers.

I’m connected via cable. Maybe my ISP use one router for several connections. Also, I tried changing the default workgroup name to some random letters and still didn’t help as well as adding Comodo’s automatically generated local area network zone to ‘My Blocked Zones’.

P.S. Apparently Windows firewall disables them by just activating some rules for selected profile. When network discovery is turned off, the rules are enabled which doesn’t let my machine to connect to those sharing ports. I think I just might add few more rules equivalent to those in Win fw. But still, that network discovery is something that bothered me since the first installment of Windows 7.

okay we don’t have such connections here (in the EU). I’m on cable too but that implies an own router. This said network discovery is a major feature in Vista/Seven. Okay, if you’re on Seven you might also want to switch from “homegroup” to classic “user account + password” method. Since you don’t seem to have any use for the homegroup feature anyway, just switch it off, and see what happens.
That’s at the bottom of advanced sharing options. Your workgroup name will then be taken into account. And this should stop other systems from appearing too in your network places.

[attachment deleted by admin]

Well, my homegroup is completely turned off since my connection is set to ‘Public’. And that is why I find it very odd at the moment. Luckily my Comodo blocks connections to such ports as 445, 135, etc. and as I can see, these computers are in my local subnet. I use passwords on all my accounts. I currently use limited account.

so may be switch back to “private” and turn off homegroups as I suggested…

ps: yeah I forgot you said it was switched to Public

Tried that. Changing to Home didn’t do anything useful. Actually it just shared my all user folders on the network so I had to unshare that manually. Also, I can’t access those computers as if they wouldn’t actually exist. Heh, maybe it’s not my problem that I can see them but maybe theirs :slight_smile:

did you disable homegroup (ie switch to “user account + password” >>> screen shot above) after switching to “home network”?

Yes I did. I noticed that this is not homegroup related. Those computers appear no matter what I do with my homegroup settings. Hmmm… I’m out of ideas.

lol, remains just one thing, leave “homegroup” on, and select what you want to share from the homegroup settings, i.e. nothing…just to play it safe ;D You should also call your ISP and ask them about that network behavior…

Well, did that but it still shared my Users folder… ■■■■, Microsoft really wants me to use their firewall it seems. I have nothing shared according to ‘net share’ in cmd :slight_smile: I think I’ll need to use both firewalls at the same time. I will never understand Microsoft.

Finally, solved that by blocking same ports on my local subnet (added that to my network zone by ip and subnet mask from cmd ipconfig). One more question, though. How can I make Comodo re-detect already detected network? Cheers. And thanks for trying to help!

just remove trusted zones (just LAN and loopback) from network policy and run the stealth ports wizard again.

Where can I find ‘My trusted network zones’? I found only ‘My Network Zones’ in network security policy. And there is only loopback zone, I apparently deleted my LAN already. However, no popup about new detected networks, nothing :slight_smile:

if you’re on V4 network policy is in the advanced features of the firewall, while the wizard is in the basic features panel; I don’t have any version of CIS installed right now, so I can’t send you a screen shot. Don’t remove any trusted zone in “my trusted zone”, these are just the pre-defined zones that you can use.

ps: the problem is that you’re not on a LAN, so you might not get anything else then the loopback zone that’s normal.

Actually it did alert me the first time and I have deleted that rule. No biggie, though.