Windows 10 upgrade - CIS won't install

Yes, I took the jump yesterday and upgraded to Win 10.

Hope this is the only problem I have. But needless to say old version of CIS premium won’t run on the upgraded Windows. Tried to uninstall old CIS and get a new version online for Win 10 but wouldn’t install. Got everything except the very last thing in. Then, installation failed.

I’m thinking remnants of old version are still in there messing with any future installs.

Question being, how do I remove each and every trace of old installation? I see a few posts on removal of CIS on earlier versions of Windows but none on 10.

Is there a removal tool available for cleaning/removal of CIS for Windows 10? There’s just a few things left, as I’ve already done an uninstall.

Probably have to do the rest manually. Need to know the order and location and methods though.

Don’t wanna ■■■■■ something up worse than it already might be.

Gathering more information, here and abroad.

Narrowing in on specifics that I shall post when sorted out.

Okay, here is the fix for the newly upgraded 8.1 to Windows 10 problem where you can upgrade or completely remove CIS premium from machine.

I assume that you have uninstalled CIS, and the Dragon browser and Geek Buddy. Everything uninstalled for me except the remnants of CIS. This prevented any other actions like reinstalling CIS for Win 10 or any other firewall for that matter. Left over stuff prevented it.

Can’t be responsible for anyone else’s experiences, but this worked for me, so I’m just sharing. Do your own research and verify, plus backup any and everything of importance beforehand.

First change your main user settings to full access admin (you can change back afterwards, in fact highly recommend that you do) Right click on start/control panel/user acc/change user account type.

After this, your file explorer view setting should be also changed to show hidden items, files and folders.

Find the “Program Data” folder and go to COMODO

I renamed it to ComodoOLD until I tested everything then later deleted it after a few reboots.

Then I got into the Registry and deleted HKEY_LOCAL-MACH / software / COMODO / CIS but left the other folder “CA”

Please backup Registry before doing this just in case. Plus I “exported” the CIS too just for kicks.

I restarted computer to make sure all was well after these actions, and so far, so good.

Then for the last remnant of CIS on my computer, opened up File Explorer again and found

“Start Menu” which had a “COMODO Internet Security” folder with a couple of things there.

This part of was the hard part as it would not let me delete the folder. Need more deeper level permissions.

Watch this video for the rather tedious steps to take in order to delete the dog gone folder!

After all this was said and done, and I changed my user log on back to standard from full admin, rebooted and now can install firewall.

Got scared,… and went with my ISP’s security software which would NOT install before either because I didn’t want to go through all this stuff with CIS.

My CIS works fine on my other computer though. It came with Windows 10 instead of an upgrade! Apparently big difference?

Good luck.

Again, be careful, and do your own research to verify what I say will work for you.