win32/giowin32.c:271: connect to reset_recv socket causes Pidgin to freeze

I run Comodo Firewall Pro together with Pidgin.

I keep getting this error around every 30 seconds in the Pidgin Debug window.

win32/giowin32.c:271: connect to reset_recv socket: No connection could be made because the target machine actively refused it.

Then after around 5-6 hours pidgin freezes and I have to restart it.

If I disable the firewall I cease to get this error. However, I have given pidgin full rights in the firewall, to access and pretty much do whatever it wants but I still recieve this error.

Could it be that there is incoming traffic that has to be allowed on the Global Rules instead of the
Application rules ? How are your global rules defined ?

Thank you for your quick answer Ronny!

In a way it solved it all, just not the way I imagined, I can’t believe I didn’t try it before.

I went into my Global Settings to take a look and the only rule I had was the basic one that you automatically recieve when you install Comodo “Block ICMP In From IP Any To IP Any Where ICMP Message is ECHO REQUEST”. I was trying to add a rule to ask me about all traffic going in and out but instead ended up removing this basic rule. When I tried to put it back I kept recieving the message “argument is invalid”. So according to another thread I went and downloaded the latest Comodo Version (even though I had version I think), uninstalled and reinstalled and VOILA! the error message is gone.

I guess that’s what I should’ve tried from the start, but instead I’ve just kept on uninstalling and reinstalling different Pidgin versions.

Once again, thank you for the quick response, it solved it. I’ll get back if I encounter it again but so far so good.

That’s great to hear.

There is also a workaround for the Global Rules deleted “Argument is invalid” that is using the Stealth port wizard to “create” new global rules.