Win task bar does not pop-up if IE is run virtualised & full screen [M196] [v6]

Hi guys,
I’ve tried to use IE in CIS6 sandbox…I noticed that when IE is in full screen, it’s impossible to visualize the Windows tray bar…unless I block it (disabling automatic tray bar hiding). Is there anyone with the same issue?
My OS: Windows XP sp3

Can you please post a screenshot of this behavior?

Uploading a short video on youtube…

Here we go

can you try disabling the green border and see if the problem still persist?

[attachment deleted by admin]

Disabling the green border everything is ok…its definitely a (little) bug.
Even VK gives me a little problem, when I close it and open any other application (word, firefox…everything) even if this aapplication runs on full screen mode, it doesn’t cover the tray bar area…

Please create a bug report for this. Be sure to follow the format provided in this post.

A. THE BUG/ISSUE:

  1. What you did: opened IE in CIS6 sandbox
  2. What actually happened or you actually saw: If the IE window has the green border, then in fulll screen mode is impossible to visualize the Windows tray bar
  3. What you expected to happen or see: visualize the Windows tray bar in any case.
  4. How you tried to fix it & what happened: disabled the IE window green border.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: No software compatibility problem afaik
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): IE 8.0.6001.18702
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: just run sandboxed IE and see if on full screen mode you can visualize Windows tray bar
  8. Any other information (eg your guess regarding the cause, with reasons): it’s a bug related to the green border. Disabling it, everything is ok.

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): see attached

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: see attached
  2. Screenshots illustrating the bug: see the video
    traybar - YouTube
  3. Screenshots of related CIS event logs: none
  4. A CIS config report or file: none
  5. Crash or freeze dump file: none
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: none

C. YOUR SETUP:

  1. CIS version, AV database version & configuration: CIS 6.0.260739.2674, AV database 14734, CIS proactive security.
  2. a) Have you updated (without uninstall) from a previous version of CIS: no, intallation from scratch.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: no
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?: no
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Enabled HIPS, switched to Proactive security, modified firewall config.
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: D+ ssafe mode, autosandbox disabled, firewall on custom policy, av default settings.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows Xp sp 3. 32 bits, admin account.
  7. Other security and utility software currently installed: sandboxie, mbam (on demand), emsisoft (on demand).
  8. Other security software previously installed at any time since Windows was last installed: Avast free
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: none

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post

  • Please append a diagnostics file
  • Please append a screeshot of your full killswitch process list
  • Are you running with UAC on or disabled

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again

Mouse

Done, except for the UAC request: running Windows XP, I don’t have any UAC. I simply run an admin account.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

FWIW I have the same problem. With IE9 fully virtualized (on Win7 SP1, 32-bit) the taskbar will pop-up with no green border but will not pop-up with the green border. With Dragon and Firefox fully virtualized the taskbar will not pop-up whether the green border is there or not.

Interestingly, and with all three browsers, if I deselect full-screen and stretch the window so that it fills the screen the taskbar will pop-up at all times.

I hope this helps some. PM me if I can help more.

Thanks for the feedback, it’s good to know it’s been replicated.

Seems to be fixed in 2708, can wonderlust76 also confirm?

We believe this problem to be resolved, so I am moving it to resolved issues.

If you feel it is not resolved, now or at any time in the future, please PM an active mod who will move it back to the main board for consideration. When it is moved please add to the topic your reasons for believing it not resolved.

Best wishes

Mouse