win 8.1 remote desktop problem - CIS v8.0.0.4344


I have read the post and added rules but no use. I’ll describe in step by step what I did and I hope someone can point me to what I did wrong:

[ol]- In the “Advanced Settings” Panel, I selected “Global Rules” under “Firewall”. Clicked the “Add” button.

  • 2- In the “Firewall Rule” Panel that opens, I have the following values:

[li]Action: Allow

  • Protocol: TCP or UDP
  • Direction: In or Out
  • Description: Windows Remoting
  • In the “Source Port” tab, I selected “A Single Port” from the Type list, and typed “3389” in the Port field.
  • In the “Destination Port” tab, I did the same thing as the “Source Port”.


  • After the rule was added to the Global Rules list, I moved it to the top of the list.
  • Then I selected “Application Rules” from the left hand side under “Firewall”. I clicked the “Add” button.
  • In the “Application Rule” panel, I set the “Name” to “C:\Windows\System32\svchost.exe
  • Then I clicked the “Add” button to add a custom rule. In the Firewall Rule Panel that appeared, I set the values exactly like the Firewall Rule mentioned above.
  • Finally, after the rule was added to the Application Rules, I clicked the “Purge” button.[/ol]

Now at this point I still cannot remote connect to my machine. The only time I was able to connect was when I disabled the “COMODO Internet Security Firewall Driver” from my network adapter’s properties.

Any help will be much appreciated.


Hi MBarjawi,

Welcome to the forums!
Could you please change the ‘Destination port’ for both rules to ‘Any’ or a port range 1025-65535.

Normally a system that is initiating the connection picks a random ‘source’ port in that range and then knows based on remote desktop protocol the destination is port 3389.
Making every session have a new random source and a fixed destination.

Now your sitting at the other end, your the server in this case so Source = 3389 and Destination (the source of the system connecting random port) = either Any or range 1025-65535.

port range 1-1024 is reserved.

Hope this helps.