will not update

Using 3.9
I can not update at all…only says virus database is out of date.

I get bad connection messages which is simply not true.
Any hints?

The database format has changed and any version older than 3.12 (If I remember the cutoff point correctly) will no longer be able to update the virus definitions.

You will need to uninstall version 3.9 and install a newer version.