Widget doesn't update 'Unrecognized' files count

A. Widget doesn’t update ‘Unrecognized’ files count then app is running from removable device (aka USB-flash)
Can you reproduce the problem & if so how reliably?:

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Run unrecognized file from USB-flash
2: No changes in widget unrecognized files count, but it shows in filelist on click
3: Run another unrecognized file from USB-flash
4: look at p.2
5: Run unrecognized file from local HDD and ‘widget unrecognized files count’ immediately updates in according to ‘filelist’s unrecognized files count’ (3 on current example).

One or two sentences explaining what actually happened:
Widget doesn’t update ‘Unrecognized’ files count then app is running from removable device.

One or two sentences explaining what you expected to happen:
The information should be updated immediately regardless of the location of the app.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:
CIS, Proactive Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS - On, Safe Mode; Autosandbox - Off; Firewall - On, Custom Mode; AV - On, Cumulative Scanning
Have you made any other changes to the default config? (egs here.):
HIPS - Block w/o alerts; Firewall - Block w/o alerts; AV - move to quarantine w/o alerts; Viruscope - Off, Website filtering - Off
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Updated from CIS
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
WinXP pro SP3, UAC - N/A, Administrator’s account, no VM
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

Diagnostic file is attached, KillSwitch - don’t use it.

Hi, Xeno.

Thank you for reporting. We checked the issue and it was reproduced on test environment. We will escalate the issue for our developers team and it will be fixed as soon as possible.
Please check your PM.

Kind Regards,

Hi, Xeno.

Please check your e-mail. The issue was solved in CIS v10.0.2.6346 Beta. Fix includes in Comodo Internet Security v10.0.2.6382 - BETA3.

Checked on VirtualBox, it seems like fixed in last beta.

But found another issue during testing: widget unrecognized files count doesn’t change if file already has Comodo rating “unrecognized”.Tested file from local HDD.
The issue is reproduced on both and - BETA3.

Was an exe file or a script file such as .cmd, .bat, .vbs?


Please check again with and provide exact steps if issue still occurs.