Why my CIS automaticlly block website?

I’m a new user on comodo CSI.
And it’s a great software, and now i’ve been using the CSI for three days,but it has a little problem right now on automaticlly blocking my searching web.

When I turn on the button “Enable the website filtering” ■■■■ the “Firewall” section, my attempt to using the searching web by ixplorer was failed. I’m now using COMODO Internet Security free version.

And i try to fix it myself by resetting the firewall rulesets, but i failed. It’s annoying me very much that I have to switch
off the “Enable the website filtering” selection.

Strangely , I can go to other website without any problem, just this my local website…

Some says that COMODO setup process include the redefine the DNS addressing. And to fix that problem , I should alter the DNS addressing automatically in local link .
I tried this method ,but the DNS was at the auto-gaining state already. And the “nslookup” command in CMD was still the same with or without the “Enable the website filtering”.

It drive me crazy , somebody do help me find what the problem is …


And i tried to put the webbrowser into "allowed application"section, problem is still the same.


In webfiltering section , I used the “Rules” and “categories” to make the blocked web site into “let it go” state, but it didn’t change anything like it didn’t work .
Here is my setting:
categories-------exclusion-------add website----------the blocked website(eg:keywords)

back to “Rules”

Rules---------add----------categories------add--------exclusions-----restrictions-------slect the current user------action:allow