Why does the GUI open on bootup?? [RESOLVED]

As problems go this is probably minor, but it is annoying…

We have 2 Win XP Home SP 3 systems using the Comodo Firewall v 3.5.57173.439. Each time one boots up (and occasionally when the other boots) the User Interface opens over the desktop. We could always see the icon open in the notification tray but that was all that happened to notify us that Comodo was running. But recently both systems have also begun to experience an opening of the GUI as well.

It’s simple enough to click the “X” to close it but it is annoying. Is this a bug or is there a setting that can prevent this from happening??

See this:

https://forums.comodo.com/empty-t24517.0.html

Or: In CIS click Misc > Settings > uncheck “Automatically start the app at startup…” > click “Ok” > open “Settings” again > check “Automatically start the app at startup…” > ok.

Should be ok now.

It's the "-h" option on the CFP.EXE registry startup entry that starts CFP silently & minimised (works on shortcuts as well). The easiest way to reset this entry is to open CFP - Miscellaneous - Settings - General and uncheck "Automatically start the application with Windows (Recommended)" & then hit Apply. This will remove the registry startup entry. Then go back, check the entry "Automatically start the application with Windows (Recommended)" & hit Apply again. This will create the registry startup entry for CFP (with the "-h" option).

I tried what you suggested but I got a pop-up saying something like “Failed to change aotorun settings. Make sure you have administrative rights to change setting.”

We are each the only users of our systems and, frankly, I don’t know what to do to get these administrative rights.

There is also no “Apply” to click on, only an “OK”. I assume that’s the same?

Please wait a bit…I’m researching it. ;D

Ok…this might help (I use Windows Vista, so I’m trying to remember about XP. Please bear with me, as I may not write the button names out properly):

Start Menu > Run > type “Regedit” > navigate to this key:

http://amymyq.bay.livefilestore.com/y1p1F25tCKAENaw1i6Ot9Px54tF5fdhd3ngqjxinPlT9TpL1isMnNUCIMIr4Jvq9m5_Gu3VhYd9ctA/1.png

Double-Click the CIS entry:

http://amymyq.bay.livefilestore.com/y1pt-e3NvMeOiVrkDOJvgD4BFZvvBCP4H0ZAJ1OIy7Wp9J9V5IsLvGLrWM9-oJK-xQV7bIonjPji7U/2.png

Change the Value to this and then click “Ok”:

http://amymyq.bay.livefilestore.com/y1pt-e3NvMeOiVnQ97yWUf7q00VCAMWdOcVS8cPKFQmKU5FdEotqdruDDbQASLJ7dpPy8jfaa9CO60/3.png

Thank you. I’m going to create a bookmark of your suggestion just in case.

What I did was to use the Microsoft SysInternals program “AutoRuns” to turn off the auto-start feature of Comodo. I don’t know why I can change the autostart feature using AutoRuns and not by using the “Settings” menu but that doesn’t matter now. I rebooted the system, checked the “Settings” and it was still, indeed, OFF. I ticked the box to turn it on and again rebooted and the GUI did not open. I have my fingers crossed that this has addressed the problem.

If it does not, I take it from your illustrations that the registry value for a Firewall that does NOT open silently will lack the -h after the file name and that what I must do is add a space and the -h after the file name if I want a silent minimized opening?

Yes, you have to add the " -h" to it, to make it start minimized. I sometimes use it for other programs too. :slight_smile:

I’m running ver 3.5 of the Comodo Firewall. Just recently, the UI has started opening when I log into Windows. It did not used to do that. How can I return it to the original startup mode, where the icon appears in the tray, but the UI does not pop up? I can’t find a setting for that.

Hi, there are a few other threads for this issue, please check them out:

https://forums.comodo.com/firewall_help/cis_starts_maximizedbug-t32176.0.html
https://forums.comodo.com/firewall_help/why_does_the_gui_open_on_bootup-t32511.0.html

Sorry I missed those before posting! The -h switch in the Autorun entry fixed the problem. I had to reboot once with no switch (I removed the -h that was already there!), followed by a reboot after re-adding the the -h. Don’t know why the original -h did not work!. I had to use regedit to do this, as I got the permission error reported in the other thread when I tried to change the setting using the CPF UI.

You can delete this thread if you like, since there are the others.

OK, glad to hear that! I’ll merge the thread with one of the others, instead. As this is resolved I’ll also lock the thread. If anyone wish to open it again, please send a PM to any moderator and we’ll be glad to do so!