Why does CIS check internet each time I open a file?

I don’t really understand why do you need comodo firewall if you need firewall only. Use WFC, as Eric said, or tinywall or simplewall (if you don’t mind the russian developer)

Now now now less of that language, as this community isn’t the place for it.

Now I’m going to ask you politely to either delete or change your above comment.

Thanks.

1 Like

ok, sorry for my behavior. topicstarter seemed rude for me.

1 Like

That’s no problem, in future if you see something that you don’t like or you’re unsure about please contact an active moderator via the tag @moderators or anyone with a shield next to their username.

Thanks for removing or changing your post it’s extremely appreciated.

The world-renowned Center for Internet Security CIS understands check internet each time I open a file

feitrouyolehu-3452, sorry, forgot to ask your opinion.

Back to the topic.
CIS is also knocking on the internet from time to time, when I click a link in my email (one application) and I open this link in web browser (another application).

Basically, it tries to check (or leak?) everything I do, even though it is not supposed to.

hi @feitrouyolehu-3452 , it can be because of below reason which I explained earlier.

can you please check if that might be the case?

1 Like

It is not just CIS, every AV I have used is doing the same thing and I think now it is a standard among the AV companies to develop products with these spying features.
If you want to avoid this, I think the only option is to uninstall all the security software and focus only on what windows offers (which btw also features build in spyware modules).

It probably is the case, but why?
I only have a firewall enabled and this is not how firewall should work.

cmdagent IS part of the firewall and this is precisely what a firewall should do, monitoring the traffic between your machine and the web. When you open a PDF file, you basically ‘open it with’ a software which attempts to connect. Switch the firewall settings to “custom ruleset”, uncheck “Do not show popups alert” and you will get your answer. :slight_smile:
If you are blocking cmdagent you basically block your firewall to be the firewall.

Another person with zero understanding giving advices in here.
Looks like easier to switch to a different firewall.
Cheers!

There is an option in firewall settings: Create rules for safe applications.

So you have no idea of what you have installed and you’re calling me a person with zero understanding, while I am fully aware of the firewall’s OSCP check. Nicely done!
And yes, that is firewall being firewall because you cannot stop it, even when you think you did. I am not saying I like it, but it is what it is…

Hello, I’m sorry, but how do you see that CIS checks the Internet every time you open a file. I have never noticed this in myself and I have never encountered such a thing. Thanks for the answer.

I was also curious to know how he knows?
Could you show us on the forum? :upside_down_face:

He blocked the ‘cmdagent.exe’ in the firewall and when you do that you can see all the programs attempting to connect within the ‘Network Intrusion’ section, in the firewall box on the main CIS window.
In the first post you can see how cmdagent.exe is blocked while attempting to connect.

2 Likes

Thank you my friend, now I understand. :smiley:

1 Like