Why did Comodo forget rules that I set when It restarted?

okay, so When I was in Google Chrome, I told the firewall to remember a lot of rules and I also told it to remember a lot of programs that were safe. About a minute later, my computer froze up and it said that Comodo firewall wasn’t responding and so I closed it. I then reopened it. I then went to the computer security policy to check all all the rules that I had set and they were all erased as if I never set them. However, I did set them and used remember my answer. Why did Comodo do this, and what If I don’t see any of my rules that I already allowed since CIS erased everything?

I suspect the freeze appeared during the ‘saving’ of the settings.
Beware that on large policies the save can take a while (like a few seconds) that also might feel as a freeze, during that time the CIS GUI is also unresponsive.

thanks for your response. I wanted a lot of security for my firewall, but I’m wondering if putting the firewall both in custom policy mode and paranoid mode for defense is too much for the firewall to take.

Its fine for the firewall, but may depend on the users preferences.

It should be fine for both Firewall and D+ it should not ‘lose’ rules it could only take longer and longer to ‘save’ an answer with ‘Remember’ set.

if I have defense and firewall set to high defense and since I’m not really computer savy, would the wise approach be to just allow everything that is safe, even when it tries to create a temp folder even when it says it is safe and only worry about what is not safe?

I wouldn’t set Defense+ to Paranoid if your not really computer savy, to much alerts, and to high a risk to become ‘numb’ to the alerts that you might allow something that could be dangerous. I’d run ‘Clean PC mode’ first for a while.

Firewall can be run in Custom policy, but I don’t recommend to put it in to ‘very high’ alert mode, use medium.
Set ‘Create rules for safe applications’ and untick ‘Do not show popups’.

Well I understand not setting defense plus in paranoid mode, but I’m not sure about the firewall in medium mode. Wouldn’t that reduce your security too much? I always though high or very high was the way to go because I figure if someone is trying to do something with your internet, it won’t be able to access it because the firewall is so strict.

I’d recommend setting it up like this. I find it to be a very good balance.

thank you Chiron, my only question is, does putting the firewall in proactive config take away the outgoing all applications rule or do I have to delete that rule manually after I set up the firewall?

It gets rid of that.

Just to clarify. The CIS 5.5 firewall application rule that allowed all applications to make outbound connections has been removed in CIS 5.8. However, CIS 5.8 introduced a new option, which is enabled by default and may be found under firewall behaviour settings, which does something quite similar to the aforementioned rule. The option is: Do not show popup alerts and is set to Allow Requests. If one changes the security configuration to proactive, this option is disabled.

okay thanks.

It’s still there in the Internet Security configuration.

Curious. When I install the full suite with the default options I get the results shown in the images. This is what I’d expect, as the old ‘Allow all’ application rule is no longer part of the COMODO - Internet Security.cfgx configuration file.

CIS 5.8 - COMODO - Internet Security.cfgx

CIS 5.5 COMODO - Internet Security.cfgx

Did you upgrade or fresh install?

[attachment deleted by admin]

I think the current 5.8 still allows ‘trusted’ applications out regardless of the ‘All applications’ rule, but I’m not 100% sure… it changes to fast to keep track :-X

It does Ronny, but that’s because of the ‘Do not show popup alerts’ under firewall behaviour settings. Try it…

Does it still alert for an ‘unknown’ application then? or is that also allowed to phone home?

I posted a response in another thread that’s related Re: about the private data