Why Comodo does not update to the latest database version?

Actually I have database version 22952, but I see that the latest version at this moment is 22958. Nevertheless, if I try to update, I get the message that everything is ok, and properly updated.

i also get stucked on 22952… but i sometimes get an error when trying to update: Error: 0x80070057 - Falscher Parameter or Error: 0x80004005 - Unbekannter Fehler.
and sometimes it tells that it was updating, but still the same 22952 is there…

the last CIS update is a big fail: executables that have been rated as trusted are seen as unknown… computer hangs on shutdown… crashes and all the already solved old issues are back… :-TD :frowning: 88)

I’m still stucked on virus db version 22952. The comodo tells me that the database is updated and everything is fine, but I know that the latest virus db version is 22960.

Is anyone of the Comodo staff who can tell us what is happening?

Can you do a manual update then check logs on that screen bottom right corner before it closes, on main screen after update is finished should show everything Completed.

I seem to be stuck a bit further back.


Edit Added Main screen which shows no problems.

[attachment deleted by admin]

same here, main screen shows no problems.
in the logs i get version 22953.

[attachment deleted by admin]

Same here.

When Comodo staff will fix this issue?

The problem persists.
Dennis2, you are a global moderator. Can you draw the attention of anyone belonging to Comodo staff on this issue?

same here…
problem persists 88)

To fix it:

Uninstall Comodo using the usual Windows uninstaller (don’t use other uninstaller programs).
Reinstall it.
The Comodo updates to the latest DB version.

I don’t know if there will be further problems in the future. For now I’ve the virus database perfectly updated.

Sorry it took so long to remember this :frowning:

CIS stores it virus downloads in Program data so if you happen to have a corrupt one because of the download problems it keeps using it.

Please note you may have to change you settings to see hidden files in Folder settings/view

Please go to ProgramData/Comodo/Cis/wpTemp in this folder you should find all the downloaded base files I deleted them all.

After this tried to update again no problems now up to date with the current database.

Any queries please post, sorry did not take screenshot of Folder think I had about ten different ones.


Thanks Dennis2. Very useful. I’ve fixed the second PC I have (in the first one I had already re-installed Comodo).

Glad it helped :slight_smile:

I tried just deleting the 1kb files on my VM which worked aswell.

Screenshot below showing some of them as it was 12 days since I last updated it.


[attachment deleted by admin]

Yes, the corrupted files are only 1kb size.
I had just one to delete.

i’ll tried Dennis2’s hint. it worked, i deleted them all. thanks. :-TU
hopeless programming if it takes the corrupted file instead of downloading it again. “comodo loves me” but i am not sure wheter i love comodo…
i am getting tired of it. :-TD >:( 88)

Thanks for posting back :slight_smile:

I admit it was a unusual set of circumstances, but instead of notifying you of the problem that one of virus database downloads was corrupt it said it Completed the update.

To this end CIS now said it was Secure even though you xxx days out of date.


yes and it downloads all the new definition files, but is not installing them, caus a previous is corrupted…
now my wpTemp folder is empty…
i wonder whether those files go there only when they are not installed. so if there is a corrupted one for example the following ones go to the wpTemp folder, untill they are finally installed? but if there is a corrupted it should be deleted automatically or at least a warning should be shown…

Hi Dennis:

I updated program to version, and problem persist.

I can´t update nothing and report of errors show Error: 0x80072efd - No se pudo establecer una conexión con el servidor.

Any suggestion?

Thanks in advance.


Sorry that is a different problem (actual connection to update server) please start a new topic.

Or try this suggestion here.


Reading what Rafamayt is saying, is better do not upgrade to the latest program version.