Why am I seeing this error "The defence+ is not functioning properly"?

I’m trying to find out why I get this error message “the defence+ is not functioning properly”
I even tried deleting & re-installing the program but the message is still there. When I run the diagnostics test it says nothing is wrong.

Do I need to change a setting or something?


Even i’m getting this same message but diagnostics says every thing is fine… ???
i was running comodo with antivir…so i thought may be there is a clash n removed antivir and then re-installed comodo…but still the same problem… ???(os:windows xp sp2)

Anvir and Comodo get along just fine.You need to do a complete uninstall and reinstall of Comodo. You cannot just delete it. I use Revo Uninstaller in advanced mode and when Comodo says reboot dont and click next on Revo. Then delete the left over registry and program entries it finds hen reboot. Also read all the sticky notes under important topics such as this one.


Hi nasty and thetranceclover,

What option did you choose when installing cpfv3.

Have a look under Miscellaneous/Manage my Configuration/Now click on “Select”
There are two options,the one you have running should be greyed out and have a tick next to it.You should have the option Comodo-Optimum security ticked and greyed out,also check Defence+/Advanced/Defence+ Settings to make sure “Deactivate the Defence+ permanantly” isn`t checked.


Hi Vettetech and Matty…Thanks a lot for your help guys…

Vettetech…i tried wat u suggested…

uninstalled comodo and safe surf using ccleaner…and then without a reboot ran the ccleaner cleaner and registry cleaner…also manually deleted temp files.
Rebooted and then deleted the following…
C:\Documents and Settings\All Users\Application Data\comodo
C:\Documents and Settings\All Users\Desktop\COMODO Firewall Pro
C:\Documents and Settings%user name%\Application Data\Comodo
C:\Program Files\COMODO

However i could’nt find the following files…

they seem to have been already removed…

Then removed all the registry entries except LEGACY ones as mentioned by USSS in the link you posted…(some entries seemed to have been already removed)

Reinstalled comodo with default selections…n rebooted…but no go…the same damn problem.

Also tried the same procedure using Revo Uninstaller in advanced mode…but the problem persists.

Matty…i installed it with default selections…
“Comodo-Optimum security” ticked and greyed out.
“Deactivate the Defence+ permanantly” is’nt checked.

Umm from what I am reading you did it wrong. I never said use CCleaner to uninstall. If you currently have Comodo installed then open up Revo and uninstall Comodo using the advanced mode selection. When Comodo says reboot,don’t and click next on Revo and delete the left over registry and program entries it finds then reboot. Click No on the Comdo prompt to reboot before clicking next on Revo. When you reboot the Windows Security Center should show you currently have no firewall installed. Use CCleaner registry cleaner and delete those items it finds. If the security center still shows Comodo active then you need to run the batch file in USSS’s first post. Its attached to the bottom. After that then reboot. Do not install Comodo till you know all traces are gone and the security center shows no firewall active. Manually search for any left over files and folders.