Whole system hangs on Comodo reboot request

Reproduction reliability:
Not really, it happens on its own every few hours/days.
Issue description:
Every time Comodo randomly says it needs to update in order to apply updates, the whole system hangs and only hard resetting can get it back to work.
Issue details:
A popup shows up asking to reboot (or plan to) to apply Comodo updates and Windows notifies that AV and FW have just been disabled. After that, the system hangs completely, as in I can move the mouse but can’t start applications, already running applications start failing and freeze completely in a matter of a seconds, start menu can’t be opened and so on.
Expected behavior:
Ability to normally reboot or postpone the reboot request without the system hanging up completely.
Software compatibility problems:
Any software except CIS/OS involved:
Other information:
Since apparently the Comodo suite temporarily suddenly turns off maybe the system hangs kernel-level. I’ve tried manually disabling every automatic update setting but this keeps happening nevertheless (!). I’ve tried waiting (up to 10+ hours) to see if the system eventually gets back to normal but it doesn’t. It once happened while the screens were turned off (by powersaving settings) and I couldn’t wake them up. The issue happens even if the system is completely idle.

Exact CIS version & configuration: build 23774
Modules enabled & level:
Antivirus: Stateful
Firewall: Safe Mode
Auto-Sandbox: ON
Viruscope: OFF
Have you made any other changes to the default config?:
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10.0 10240 x64, UAC completely off, Administrator account.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebytes Antimalware, set to be completely on-demand only b=None.

[attachment deleted by admin]

This is still happening, very annoying. Any ideas?

Have you made any other changes to the default config?: No.

Try to disable ‘Viruscope’. Does it help?


As you can see in the original post, it’s already disabled.

Which configuration are you using? Also, did you try a re-installation?

My whole configuration settings are in the original post… and yes, I tried a full uninstall & install

Please check this issue again when next (major) version is released.


Please check with Comodo Internet Security V10.0.0.6071 Beta thanks.