When uninstall CIS, CIS Helper Driver is always left behind[M505][V6]

A. THE BUG/ISSUE (Varies from issue to issue)

Summary: Please give a clear summary in the topic subject, NOT here. 

Can U reproduce the problem & if so how reliably?: Yes, anytime.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
a. I uninstall CIS.
b. After restart, I went to Device manager, click View → Show hidden devices → Non-Plug and Play Drivers. And there CIS always leave behind Comodo Internet Security Helper Driver.
If not obvious, what U expected to happen: Clean uninstall without any driver left behind.
If a software compatibility problem have U tried the conflict FAQ?: No other software.
Any software except CIS/OS involved? If so - name, & exact version: None.
Any other information, eg your guess at the cause, how U tried to fix it etc: Manual uninstall the driver seems to be the only solution to solve this problem, and this is happening since CIS v6.0 → CIS 6.2.282872.2847.
Always attach: Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex: CIS logs & config, screenshots, video, zipped program (not malware).

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

Exact CIS version & configuration: 6.1.276867.2813 Internet Security.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: All, HIPS=Disabled, BBlocker=Untrusted, Firewall=Custom Ruleset, AV=Enabled at Default.
Have U made any other changes to the default config? (egs here.):No.
Have U updated (without uninstall) from CIS 5: No.
if so, have U tried a a clean reinstall - if not please do?: I did a clean install of CIS 6.1.276867.2813 but problem persists.
Have U imported a config from a previous version of CIS: No.
if so, have U tried a standard config - if not please do: Yes.
OS version, SP, 32/64 bit, UAC setting, account type, & virtual machine used: Windows 7, SP1, 64bit, UAC=Disable, Admin, VM not used.
Other security/sandbox software a) currently installed b) installed since OS: a) None b) None.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I have received feedback from the devs that apparently this is normal behavior. The driver being left behind should not cause any problems. For more information please see here.

Thus, I will move this to Resolved.

Can it not be just uninstalled via a right click manually. :slight_smile:

Yes it can, but some users may not realise this.
If it happens to stay active it could have potential to cause issues with future applications and be hard to track down the cause in some situations, especially if a substantial period of time had passed before hand.

Actually, after additional discussions, this has been re-opened. I’ll now move this back to format verified.

Thank you.

Thank you

Yes you right that’s my point

The devs have responded. Apparently this driver cannot cause issues. Thus, it does not warrant the alterations needed to ensure that it is removed.

Thus, I will move this to Resolved.