When I Select "Block Fragmented IP datagrams" I Can't visit some website

I got problem when I visit http://delphi.ktop.com.tw/. But, after I unticking the “block fragmented IP datagrams” option, I can visit the site. Could it be something wrong with my computer or the website?
What can I do to set the rules to allow the website, but block other fragmented IP datagrams? I’d try to set a global rules that Allow >> source >> Host Name: “delphi.ktop.com.tw” but it dones’t work. Please help Me.

Thanks.

74.125.19.99

this is the IP of that site.

Add it to your allow list

It seems that the IP “74.125.19.99” is Google’s.

You are so humor.

When I Ping the site, I get:

Pinging delphi.ktop.com.tw [220.134.61.12]

I think that is the IP of the site.

So I Setting the following rules in “Network Security Policy>>Global Rules”:
1. ALLOW TCP OR UDP In/Out IP 220.134.61.12 To IP Any
2. ALLOW TCP OR UDP In/Out IP Any To IP 220.134.61.12

But it’s doesn’t work.

Have other idea?

Thanks!

I am able to visit the website with block fragmented IP datagrams checked.

Not able to read many characters, but that’s language character display i think.

Was problem maybe temporary?

Hm, I can read it with no problems. It seems to be a ‘Chinese’ forum.

Thanks for your answers.
I have been clean up the temporary files, but doesn’t work.

So, it was my internet environment?

I had try to Setting The MTU follow this tutorial:
“Adjusting the MTU” http://help.expedient.com/broadband/mtu.shtml

Setting My MTU to 1480.

But it doesn’t solve my problem.