When I open a new website it says "This website is not available"

Like I said when I start a website it says that the website is not available and I have no idea what to do. I uninstalled it and reinstalled it , open and closed the browser, and turned off turn back on again the wifi, and restarted my computer. What do I do to fix this?

Hi and welcome azriel_13,
Is this only happening with Dragon?
Is it all websites?
Does it show any error codes?
Was anything changed on the system at the time this issue occurred?

If it is only Dragon, try with 'malware domain filtering (Comodo Secure DNS) disabled, found under privacy in Dragon’s advanced settings.
Also it might be worth trying with all 3rd party extensions disabled.

Edit: Added the word disabled, which I accidentally missed adding previously.

Yes, it’s only happening with Dragon.
Yes, all websites I visit.
The error code that shows up is: ERR_CONNECTION_RESET
Not as far as I know, I was on one router then an hour or two later I went on a different router and it wouldn’t work.
The Malware Domain Filter was already activated. I just tried the disabling all 3rd party extensions, only one of them, and it’s still not working.

Hi azriel_13,
My mistake in the previous post, I missed the word ‘disabled’ sorry. :-[
Try with ‘malware domain filtering (Comodo Secure DNS)’ disabled, found under privacy in Dragon’s advanced settings.

Sadly, it’s still not working.

Sorry I am not sure what is happening. :-
Is it possible to try it back on the original router?

Well, it’s still not working and it’s back on the original router.

No promises, but I have asked the other Mods if they have any ideas of the cause or a fix.

Could you install Dragon as a portable installation? This will install a second and separate version of Dragon. It helps to determine whether your profile is the problem.

Does the problem persist or go away with a portable installation.

I just install it as a portable, and popped up saying: “User profile is not writable” then give the file destination.

With the portable version, Dragon expects the location for the installation files along with the user data to have non restricted permissions.
Try installing into a location where the user has ‘Full Control’, for example the downloads folder.

Okay, I’ve installed it as a portable in the downloads file, and it open, but it still doesn’t work.

Can you double check if Secure DNS is disabled in portable Dragon.

Yes, Comodo Secure DNS is disabled. And i have version Portable.

Does updating the drivers of your network adapter make a difference?

It seems like all the internet related drivers are updated.

could the problem be that I have both Dragon AND Chrome?

Sorry this issue is persistent, with no known explanation.

Dragon and Chrome should in no way affect each other as they are totally independent from each other.

What DNS servers are your computer using? Are they also set to Comodo? If so try other DNS servers. After changing your system’s DNS servers don’t forget to flush DNS cache: http://docs.cpanel.net/twiki/bin/view/AllDocumentation/ClearingBrowserCache .

Okay, the DNS flush was successful but it didn’t work. I tried allowing Comodo Dragon to go through Windows Firewall on public routers, in case I may have accidentally said the router was a public router, so I tried that, and it didn’t work.