When firewall on custom cannot connect to Internet!!

Feel very dumb…
When Firewall set to Custom setting, won’t let me connect at all to Internet.
To get on here for help have had to reduce to “Allow all” when it will let me on.
Don’t realy understand what to do next!!
Any simple advice appreciated!!
Thank you,
IT Newbie!!

Hi, welcome to the forum!

Have you checked the Application Monitor in the firewall? Perhaps you have accidentally created a rule there to block your internet browser?


I had that problem once before it ending up being I blocked svhost I believe, I also had “dont show alerts for certified app something” on, im not sure how I blocked it.

Here’s something you could try; I sometimes use it personally.

  1. Shut down the firewall (please unplug your internet cable first - you don’t want to leave the door open).
  2. Start the Registry Editor (go to Run and type regedit).
  3. Look up this key: My Computer\HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall\AppCtrl\IPC.
  4. Delete the IPC “folder”.
  5. Start the firewall again, and plug in your internet network cable.
  6. Now, hopefully, you should be able to use the internet.

You’ll most likely get a prompt sometime; svchost.exe trying to connect to the internet. Unless there is a suspicious parent (if you have some malware trying to hijack svchost.exe), allow it.