When are we going to get some answers with 2.4 bsod (cmdmon.sys)

Ok i’ve been running and older CF since Friday (2.3.4.45) without a single bsod and pc has been on solid for the past 72 hours, been doing all the things i was doing with 2.4 but without the dreaded irql_not_equal_to and the cmdmon.sys failure. I’ve raised it on here with a mini dump, i raised it with tech support with a mini dump and it got closed by Stewart within 24 hours with no reply or answer, it was just closed full stop.

I’ve been scanning the forums and it seems i’m not alone, i’ve done everything that has been suggested including buying a new NIC, to unistalling and installing 2.4 whlst offline,turning off cftmon.exe, yet still with 2.4 i got bsod’s. It has to be something to do with this release as 2.3 are trouble free, yet it seems no one has an answer and tech support just don’t want to know, even a reply saying “yes we know there is a problem with 2.4 and we are trying to fix it” would have been nice.

Dont get me wrong i think Comodo is an excellent firewall, i know i’ve tried them all and i dont wish to go back to them, but someone needs to let us know if they are fixing the problem or looking into it so we can safely update to the newer version knowing they have fixed the problem instead of just closing tickets without saying a d1ckie bird either way.

Thanks

hmm…
ok what version are you running exactly pls?
under what circumstances does this happen?

thanks

Hi Melih thanks for replying :wink:

The last version i was using was 2.4.16.174 but i’ve had bsod’s with every 2.4 release.

When does it happen, completly random, sometimes couple of times in an hour, then it wont do it to the next day. What am i doing at the time, sometimes nothing,pc just idle, go out the room come back in bsod,done whilst gaming on and offline,browsing,listening to music, allsorts.

Here’s a link to a earlier post with a mini dump and some specs. Like i said, the version i’m running now which is 2.3.4.45 has run flawlessly since Friday as did all versions till early this year.

https://forums.comodo.com/index.php/topic,5596.0.html

Also my ticket ID that was closed QMU-864363

Thanks

i have been getting identical problems with 2.4 versions. Identical right down to the stop codes. Three out of five of our PCs with CPF are BSODing daily. One of them got up to 7 times per day, the other was about 4 times per day and the third was twice or so.

I did all the suggestions including re-installation and still got BSODs. Basically I got the brush-off also because there was never a ticket opened after I responded to a question about the PO number or something like that - as if I needed to purchase something to get help.

If this product begins to run smoothly again there are other Comodo products that some of my clients need that they would be glad to purchase at my recommendation.

Please can we get CPF fixed so that I do not look like such an incompetent to my current test client?

Finally - (thanks for letting me rant) I un-installed CPF during the night after COB here and we did not get a single BSOD all day!! That was a first in two weeks!!!

I was just un-Installing CPF on the last of our 5 PCs and found in the Program Files directory under Comodo a couple of dump files that CPF left behind. I have attached a zip file containing them to this post. Hope it helps.

[attachment deleted by admin]

k thanks for that info…

did you try to run the latest version we have?
there were few fixes in that version.
thanks
Melih

Thanks again Melih

Right ok i’ve done as you have suggested and updated to latest version 2.4.17.183 as of now.
I’ll post back in next 24 hours and let you know how we get on (:WAV)

Hi GoonerUK

If you get some answers to our problem please post here, too:
https://forums.comodo.com/index.php/topic,6435.0.html

THX
hellraiser-rh

Well its just BSOD whilst playing a game, heres the dump file (:SAD) going back to 2.3 again.

Microsoft (R) Windows Debugger Version 6.6.0007.5
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\WINDOWS\Minidump\Mini021407-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: C:\Symbols
Executable search path is:
Windows XP Kernel Version 2600 (Service Pack 2) UP Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 2600.xpsp_sp2_gdr.050301-1519
Kernel base = 0x804d7000 PsLoadedModuleList = 0x805531a0
Debug session time: Wed Feb 14 18:10:43.750 2007 (GMT+0)
System Uptime: 0 days 1:34:44.333
Loading Kernel Symbols

Loading User Symbols
Loading unloaded module list


  •                                                                         *
    
  •                    Bugcheck Analysis                                    *
    
  •                                                                         *
    

Use !analyze -v to get detailed debugging information.

BugCheck 1000000A, {16, 2, 0, 804f8c38}

*** WARNING: Unable to verify timestamp for cmdmon.sys
*** ERROR: Module load completed but symbols could not be loaded for cmdmon.sys
Probably caused by : cmdmon.sys ( cmdmon+7e2 )

Followup: MachineOwner

kd> !analyze -v


  •                                                                         *
    
  •                    Bugcheck Analysis                                    *
    
  •                                                                         *
    

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: 00000016, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: 804f8c38, address which referenced memory

Debugging Details:

READ_ADDRESS: 00000016

CURRENT_IRQL: 2

FAULTING_IP:
nt!KeSetEvent+30
804f8c38 66394616 cmp word ptr [esi+16h],ax

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: DRIVER_FAULT

BUGCHECK_STR: 0xA

PROCESS_NAME: System

LAST_CONTROL_TRANSFER: from eb441f89 to 804f8c38

STACK_TEXT:
f7264ca4 eb441f89 86394f84 00000000 00000000 nt!KeSetEvent+0x30
f7264cc8 eb4420bd 85c09240 c000023a 00000000 tcpip!TCPDataRequestComplete+0x93
f7264cf8 eb41e23d 85c09240 86394f9c 85c092f0 tcpip!TCPSendData+0xa6
f7264d14 804eddf9 86a413a8 85c09240 85c09314 tcpip!TCPDispatchInternalDeviceControl+0x51
f7264d24 eb4057e2 eb414e90 864d0b94 864d0b94 nt!IopfCallDriver+0x31
WARNING: Stack unwind information not available. Following frames may be wrong.
f7264d38 eb40c299 86a413a8 85c09240 00000000 cmdmon+0x7e2
f7264dac 805c4a06 00000000 00000000 00000000 cmdmon+0x7299
f7264ddc 80540fa2 eb40bc80 00000000 00000000 nt!PspSystemThreadStartup+0x34
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16

STACK_COMMAND: kb

FOLLOWUP_IP:
cmdmon+7e2
eb4057e2 ?? ???

SYMBOL_STACK_INDEX: 5

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: cmdmon

IMAGE_NAME: cmdmon.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 45bc9111

SYMBOL_NAME: cmdmon+7e2

FAILURE_BUCKET_ID: 0xA_cmdmon+7e2

BUCKET_ID: 0xA_cmdmon+7e2

Followup: MachineOwner

It’s a shame but i have given up on this great firewall (:SAD), got new update today and still the same bsod, same as all the others. Actually traced it back now to version 2.3.6.81, before this one i had no problems. So it now off my pc until this is resolved. Going to miss Comodo on me pc but these bsod’s are making me (:AGY) now, it may not like my ULI chipset as i cant remember having these problems with my nforce 2 chipset motherboard i had before.

hmm… shame really…
the dev guys are well into v3 dev now…
i am sure all this will be resolved for v3…

Melih

Hi GoonerUK,

there’s no need to miss comodo.

you can use v2.3.6.81.

I think there some bug’s, however, but you can work without this f###ing BSoD’s.

If you want, i send you the Setup File (8MB).

Thanks hellraiser (:WIN), as i said i get bsod’s with v2.3.6.81 too an earlier one works ok, well saying that it turned itself off when i logged out then in to windows,network monitor was ok but all the rest had switch off and was telling me to reinstall it again, thats when i uninstalled it and left it off.

I will pop in here from time to time to monitor the situation and when i can see that the cmdmon.sys is no longer a problem i wont hesitate in reinstalling and recommending it to my customers ( i’m a pc tech) but as it stands comodo is at arms length until a more stable version is found.

Does anyone have any suggestions for a firewall solution until CPF is fixed? I hate to leave my customer more vulnerable than he has to be.

I have heard that some people use Zone Alarm for example.

Thoughts anyone?

Uuups. (:TNG)

GoonerUK

the same 2.4 BSoD’s in 2.3.6.81,too? Or other BSoD’s ?
Very interesting, on my system .81 work’s without any BSoD.

Same, but version ending .45 is fine most of the time.