What the hell is wrong with this thing...???

I recently decided to try this firewall, based on other people’s good reviews.
It seems to run fine, for a while…then all of a sudden, it starts blocking my browser(SeaMonkey).

The only way to get around it once it happens is to turn app monitoring off, or uninstall the damn program.

Not too useful like that, not is it…???

What gives??

And yes, I tried to edit app permission, it still blocks it.


Is there anything relevant in the firewall logs?

Ewen :slight_smile:

The problem seems to occur when an application trys to use my browser to ‘call home’ by using ole.

When cfp asks whether or not to block the app’s request and is told to block it, it blocks all traffic by the browser, and not just the app making the request.

No other firewall I’ve ever tried behaved like this.
And no, it is not a feature, it is a bug… (:KWL)

No, its not a bug. The firewall is stopping the communication medium, which is the application that has an established connection to the internet - Sea Monkey in your case.

What is the application that is attempting to hook Sea Monkey and why?


Hehehe…now why did I know someone would claim it’s a feature, not a bug…??? (:LGH)

Fact is, the firewall ought to block only the app trying to hook the browser, and only for the one time, as told to do.

There were a couple apps trying to call home in this manner.
One was “movie joiner”, the other was “agent 3.0”(I think)

Previous firewalls I have used were able to figure this out. (sygate, for example).

The way cfp is working, if I want to block an app trying to call home via my browser I have to reboot after having the firewall do it’s job.
Hardly a feature.

You could try NOT selecting to remember and click BLOCK. This would make the block a per-instance block. You could then shut down your browser and restart it. That’d work. :wink:

Me, I’d be more interested in finding out what junk is on my system that is trying to dial home, and why.

Whether it’s a bug or a feature - that’s determined by our perspectives and our opinions (pre-conceived or otherwise).

Hope this helps,
Ewen :slight_smile:

What is the app that is trying to “call home”?

I too have noticed the same thing. I am just a novice, but would seem you could block a application without blocking the browser without doing a work around. As to who is calling home i would hope in the near future the connections log would show as a example, “http”//comodo.com" instead of “”. Having said this I am a supporter of Comodo FW Pro. Darth

That’s what I did. Doesn’t work.
Have to reboot the damn computer.
That’s a bug, no two ways about it.

My perspective tells me it’s a bug.
My opinion, is it’s a bug. (pre-conceived and otherwise) (:WIN)

Other than that though, I like the firewall…

OK. Your next port of call would be http://support.comodo.com - the official support centre.

You will need to register to lodge a support ticket (your forum credentials will not apply on the support centre).

Let us know what response support come back with.

Ewen :slight_smile:

If it is a bug or feature depends on what the dev intended it to do.
It’s a save way to handle things. Component a uses (or wants to) component b. Component b has access to the internet. The really save way is to block component b completly because you cannot be sure what new way there is to gain access.
Now its the users turn to check if that component a should have access to component b or not.
If not, why does it try anyways?

And why do you have to reboot the system? Well, usually it should be enough to restart the application but if some parts of it stay active in the background it doesnt count as restart —> PC reboot.

Don’t get me wrong, I ain’t the type of guy who defends something no matter what. Every software has bugs, if it doesn’t it only means nobody found one yet. ^.^
But this “feature” :stuck_out_tongue: is one. Of course, you could suggest to implement a switch to the behaviour you mentioned.