What is up with this new update

These are some seriously difficult boards to Navigate. How are you supposed to just come to the forum and find a solution with there must be 50 different little forums buried all over this place ?

Anyway, this new update that automatically installed tonight is TOTALLY crashing my Vista Ultimate 64. Nothing will load on startup… No SecondCopy, No EVGA Precision, No Ad Aware… Nothing will start either. Firefox won’t crank up, IE7 won’t start up…

What is going on ? I moved from AVG to this software - thinking this was a good find, but I must say, AVG never sank my computer like this. Unfortunately, I recommended this software to quite a few people and have installed it on a few more. I had no idea Comodo would release something like this. I feel bushwacked.

I’ve uninstalled, re-installed…uninstalled and cleaned and reinstalled and it is still crashing my system… Is this it ? Am I the only one this has happened to ? Are they planning a repair ?

This version is 3.8.64739.471. Maybe we can have the old version back until they fix this ?

Problems with the update installer perhaps?
Have you tried to uninstall first, reboot, and do a fresh install of the latest release?
(i.e. download the version for your operating system and install that).

Yes, I have… even downloading it again to make sure. I just don’t get it. Literally - nothing but comodo and realtek will load on startup when I install this software. Even my wi-fi software won’t load.

I’m running a quad-core phenom, 8 gigs ocz, 2x260gtx’s in SLI on 64bit Vista Ultimate SP1 -with every available update. This software brings it to a complete stop. Nothing will load. Nothing.

I re-installed after posting and hand to uninstall to come back. This is unreal. I dread tomorrow when my customers come knocking - wanting to know what I’ve done to them with this software. I can only hope this is only a problem with Vista 64 - since most of my customers are still with XP or Vista 32.

I don’t know if you have seen the release announcement from this AM.

"Important Note for Windows Vista Users Upgrading From Older Versions

The Windows Vista users, who have CIS version 3.5.57173.439 or older installed(32 and 64 bit), are going to have 2 updates because of the nature of this release.

  • The first update is going to update some critical files that are necessary in order to continue with the second update.
  • Then the second update is going to finalize the upgrading process to version 3.8.64739.471"


I don’t know if this is your cause of issue. On XP the transitions seem to be going smooth.

I wonder if after the first part of the update some people notice something wrong, and in trying to sort it out, cause some sort of registry botch up.
There have been a few with similar type posts.
I can’t say it’s not a bug, but have you tried using Revo uninstaller.
Or doing a thorough reg scrub or two between installs.


I’ve tried three downloads of their software tonight. I’ve had enough. I’m installing Avast and going to bed.

I will tell you this - just to be clear - in case anyone else gets hammered with this. There will be others who will have no idea WTF happened to them and will have no idea that Comodo is the cause of their problems. If I hadn’t been paying attention tonight, I might have been uninstalling everything else BUT the software that is supposed to be protecting my computer.

As I said before - whatever happened - you cannot run ANYTHING once you have installed this software. NOTHING. This includes that Revo Uninstaller or Registry Cleaners. And just for fun, try finding Comodo in Revo Uninstaller in Safe Mode. :-).

Yep, I’ve learned my lesson tonight - and I will be SURE to pass on my findings to every person who calls me tomorrow - with a link to Avast/AVG and Ad-Aware. The heck with this garbage - free or not.

Same exact problem here. Downloaded this software multiple times, and on each install nothing runs on startup. I can’t even open up any 3rd party program except COMODO.
I’ve done the uninstall, reboot, reinstall. I’ve done the registry cleaning then installing etc and the problem persists. For now I’ve reverted back to my copy of 3.5.57173.439 until these issues are fixed or ill be switching (I don’t like running outdated security software). It seems to be only affecting Vista 64. It runs just fine on my virtual xp64, and 32vista.

It’s interesting to see COMODO release and “update” that fubars the os so badly that Vista can’t even run IE or Logitech drivers for my mouse.

Hope you guys get this fixed ASAP.

I’m experiencing the same problem. All of the 64-bit applications run fine, but the update prevents all 32-bit applications from running. For example, Minefield(64-bit firefox) will run, but 32-bit firefox will run. This is a pretty big deal considering my antivirus is 32-bit. I’m going to have to restore from before the update and ignore the update until we’re certain the problem is resolved.

Mistakes happen, but I don’t see how you could have missed this if you had tested the update on a Vista64 system. Comodo’s really dropped the ball on this one.

???Same problem here All of the 64-bit applications run fine, but the update prevents all 32-bit applications from running
Would have thought in testing this would have been noticed before rolling out the updates!!! (:CLP)
hope this gets sorted soon as I’ve always used and installed this on many computers and always been happy with it but this is taking the biscuit if your testing on vistax86 and x64 think one of your testers would have thought where’s my mouse or how come my firefox wont start or why doesn’t anything run in 32 bit mode in vista x64…Any half decent tester should have found this on first install :o

Working with a 64bit Vista HP notebook… Comodo was installed (as just firewall) working fine. Told it to auto-update… after it did, Comodo killed AVG, Firefox, MS IE, etc… WordPad still worked.

I UNinstalled Comodo, and everything worked… I downloaded the latest downloadable Comodo for 64bit, installed… again, dead apps - dead 'net access.

Uninstalled Comodo.

Going to look for my old install file… or just not run Comodo till I find out, here, the ‘fix’ (notebook is behind NAT/router).

If there’s a second update… and the first update kills 'net access… how are we supposed to get it?
Do us all a favor… fix it to one update… that works and plays well with others (esp. when installed as just firewall). Thanks

The solution for this i read in other thread is disable defence + to do this go into comodo on the top tabs click on defence + then on left click advanced at bottom of page is defence+ settings click on it then at the bottom of page is disable defence+ permanently(needs restart) then everything works again so far :BNC

Hey guys, I found a link to download an older version of Comodo straight from the Comodo website - http://download.comodo.com/cis/download/setups/CIS_Setup_3.5.57173.439_XP_Vista_x64.exe

Also, since this issue (After uninstalling Comodo) I’m experiencing “Stuttering” every 10-15 seconds where my CPU usage jumps to 90% for a second and then back down. Very annoying!

This version, 439, is the only one that works for me.
Version 3.8 is a disaster as far as i am concerned.
Lets hope it all gets sorted in the next yersion.

That did it. But now the ‘all in one’ solution is no longer an ‘all in one’ solution. Additional programs like spybot s&d with ‘tea timer’ protection will be needed. I was blindly onboard with Comodo… but after peaking under the hood and with what I witnessed this weekend on these forums - moderators and even the CEO burying their heads in the sand with this 64bit issue - I can’t say I would recommend them anymore.

I truly believe that if more time was allociated in sorting out peoples problems rater than adding more BELLS and WHISTLES would result in a far more stable program.
It looks like Comodo have fallen into the trap that has befallen many other security companies
Does it really matter if it takes a year or eighteen months
In the end you have a first class stable product.

I removed Ad-Aware and Voila - now everything works. Now to straighten out my customer’s computers.

Kudos to Ronny for asking the right question.

Removing Ad-Aware??? Not a valid solution, as far as I’m concerned. I don’t have Ad-Watch running in background… so why should Comodo ■■■■■ things up? I will test this… but if I were to choose to remove something… Comodo would go first… back to an older version at least… or a competing product.
Any program that updates and screws formerly working applications… gets ripped out first.
Comodo needs to address this properly and not just leave the rest of us hanging.

I will test disabling the Defense+ option as well… if subsequently, there is a ‘second stage’ update that allows Comodo to work and play well with the rest of the system/programs… then fine. But Comodo needs to make this WIDELY known… if this works. Ad-Aware stays.

[Edit] Ok… another thread… the dev’s are working on the problem… I will await their fine fix :wink: