What flag should I set to suppress this message and others like it?

“The latest version of Adobe Flash Player must be installed to view content from this website.”

I’m keeping Flash Player blocked and I don’t care if I have the latest version installed or not. I don’t want to get this message. How do I prevent it?

NB It comes on a banner with an arrow pointing at the far left of the address bar.