We've detected you're using and older version of Chrome

I am seeing this message “We’ve detected you’re using and older version of Chrome” with a button to Update to stay secure. Why am I seeing this? I have the latest version 52.15.25.664? Should I use the button to upgrade??? I wouldn’t think so but thought I’d ask. Thank you.

Comodo Dragon is way outdated, current version of Google Chrome is 57.0.2987.110. I am using Vivaldi beta and SRWARE Iron. Vivaldi is version 57 and Iron is version 56. You can try the beta version, still outdated as it is version 55. Comodo Dragon Release Candidate Version 55.0.2883.58 https://forums.comodo.com/beta-corner-cd/comodo-dragon-release-candidate-version-550288358-t118375.0.html I switched browsers as I gave up on comodo for web browsers.

About SRWare Iron, http://www.insanitybit.com/2012/06/23/srware-iron-browser-a-real-private-alternative-to-chrome-21/

Vivaldi is good choice and I am using Opera Beta web browser (v57.0.2987.88 )