Western Digital Hard Drive Not Working Please Help

Hi please can you help me,

I downloaded Comodo Disk Encyrtion 2 days ago. I followed the process to encrypt a hard drive ( I encrypted my Western Digital Essentail External Drive) I showed all encrypeted when finished, however I now have problems when I try to access the process now.

When I want to add encyrpted drives, it shows the drive (H in this case) from the drop down tab, then the window come up with data password etc.

It keeps coming up with Error, make sure this is a encrypted drive, you have the right passwords etc,
I know I have the correct passwords etc. That it is a encrypted file as it wont even let me format the drive!

Another thing I have noticed is that is says when I start it up (comodo) that windows has changed the drive I am trying to access ?

I have viewed the drive file system and it is RAW but sure it was set to be NFTS? PLease can you help many thanks Gaz.

Hi gourmetgaz,

Can you post some screen shots of the CDE including this error?

And when you say it show’s RAW that’s from a windows disk manager? Because it’s encrypted windows can’t identify it and marks it as RAW until it’s “mounted” by CDE under windows this will result in 2 drive letters.

  1. for the encrypted drive RAW and 2) for the “CDE Decrypted” drive.

Did you note the encryption parameters you used also?

Hi Ronny, (sorry about posting twice)

Tried screen shot it didnt work but this is the message that comes up,

COMODO Disk Encryption

Cannot add encrypted partition.
Make sure that this drive was a CDE encrypted partition and that encryption settings and password are correct!


Also in the computer managment in control panel is explains the H drive as a Raw file, Healthy, Primary Partition?

Ronny can you help in any way thankyou Gaz

You can add a file by clicking on the >Additional Options… on the bottom of a new post and then click browse and select the image to attach.

And are you sure you used the correct Hash en Encryption algorithms ?

As i posted before is the H drive the drive that shows up in Explorer if you attach your USB disk?
That’s the drive windows will see as “RAW” because it’s encrypted. It will show a new drive letter if CDE is able to attach to it with the correct settings.


I am sure I have the correct Hash and Encryption algorithms, but I have tried all varients.

Yes the drive does show in explorer/my computer as “H”

I am a novice at this so all help is very well recieved.

Ty Gaz

Was the drive attached to the system during system startup? and if not can you try that?

The drive was attached during startup, have tried attached and unattached. The windows item that comes up saying the system is aware disk has been changed you are to restart windows, comes up every so often ? Is this any help cheers Gaz

So you only encrypted your external drive?
That must mean that CDE somehow recognizes the external drive because otherwise it would give an error telling that it could not find an encrypted partition…

Did anything else happen after encrypting?

I’m not sure about the disk change warning, looks like the OS is interfering… do you have the exact message?

Ronny I dont at the moment will try to get it, but yes I think the OS is interferring. Is there a way of stop altering this, it does automatically come up in the box to be encrypted (the only one that does)

When it encrypted I close it all down and that was it, then when I tried to acces it no luck and was stuck trying to get in!

Will try and get that message up again, and drop you a line ty Gaz


In the odc attached are the 2 items that come up, I did the restart with drive attached then opended Comodo,

Ty Gaz

[attachment deleted by admin]

I’ll see if i can find someone else to jump in, I’m out of options.
Did you make a backup of your important data on that drive?


I have some questions in order to help you:

  1. which CDE version have you used?
  2. The encryption process finished successfully?
  3. After restart CDE says that “There is a problem with the encryption subsystem” ?

You do not need to mount your encrypted disk after restart, the disk should be accessible after restart, all you have to do is to type the password at boot time.

Hi Ionut,

I am using the CDE 1.2.114847.152.

Yes I am under the impression it was done correctly, it was fully encyrpted etc and showed so on the splash screen.

In the attached doc below it can splash up with an issue saying the encryption (please see my last post) and on boot when the password prompt is ticked it comes up but wont alllow me to enter and thing, so windows fires up and then, when I try CDE no drive shown I have to try to find it, although it is shown in My Computer!

I am desperate to try and find out what to do, can you help? Many thanks Gaz.

Hi again Ionut,

Another thing I noticed was before my Western Digital drive was classed as a Removable drive, after the encryption for some reason it is now classed as a Local drive within My Computer, dont if this has any bearing on the matter?

Ty Gaz.


During Boot time you may tipe your password(no echo). Even if any key is not displayed just keep typing.

Pls let me know if it is working.


Sorry I dont understand, should I put in the password (at the prompt stage) before windows starts up? It wont let me action it though (the cursor doesnt move and no words are typed)

I will try again, sorry dont know what echo means also, I am not that computer literate, ok but not to good, so anyway you can help is much appriecated, TY Gaz

Yes that’s the procedure, you need to type the password and it won’t show anything moving ** etc
Just type the password and press Enter, then it should mount on boot. Of course the drive should be connected to the system during bootup…

Ronny & Ionut, :BNC

All I can say is thankyou from the bottom of my heart, I typed in the password at boot up and the system works fine.

You 2 have saved me a huge amount of time and pressure, all I can say is thankyou for your advice and help you are both stars.

All the best from a very happy Gaz (in the UK) have a great New Year :-TU


Hi Gaz,

Glad you have access to your disk again :-TU

Have a great New Year also!