Weird NIC behaviour [Resolved]

I’ve installed CPF on my gf’s old computer and it worked fine. In December, she got a new computer and it did work fine until she had to buy a router to share the internet connection with the rest of the household. She couldn’t get the type I recommended so she had to settle for a Linksys WRT54G-UK wireless router. She has ADSL that uses PPOE (Netopia 3000 Modem). I had problems trying to get the IP passthrough to the Linksys router (worked from the Netopia modem to one of her NIC’s but not to the router). What I did then was to hook up her ethernet connection to the router (works fine) and use the USB connection as the IP Passthrough whenever she needed a VPN or wanted me to troubleshoot a problem on her pc when I’m not around.

The arrangement worked fine until sometime last week. Upon a reboot, she could only get connection on the NIC that went through the router. The second NIC (USB connection) would register an IP address of I got her to disable CPF by chosing allow all and renew the IP or disable and re-enable. That caused the IP to be renewed and workable. However, the moment CPF is set back to the normal settings, the NIC disconnects, tries to get an IP address, fails and is thrown back to the address. I’ve removed and reinstalled CPF to no avail.

Now, she’s stuck without a VPN as getting the linksys to first register the external IP through IP passthrough hasn’t proved successful. For one, it doesn’t have a setting for setting static IP addresses. Any advice/help would be appreciated.

:BNC Just wanted to say that I got the problem resolved. I had to go over and check on her pc paying particular attention to the logs once I turned on the firewall after disabling and re-enabling the NIC in question. Turned out one of the SCVHOSTE.EXE files were blocked upon closer scrutiny. Once I unblocked it, everything went smoothly. What I can’t figure out is ??? why would there be two different scvhost.exe entries for the separate NICS? Gosh, Microsoft is so weird with their implementations.

Glad to hear you got that figured out, emmjay. I’ll mark the topic resolved for other users’ benefit.

I think you’re probably spot on, to say “Microsoft is so weird with their implementations.” :wink: