Weird default port value [MN]1[v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, 100%
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
  1. Create a rule with “a single port”. (does not matter if source or destination).

The port field is filled with value: 65533 by default. Reason - unknown. This field should be by default either empty or 0 (for a port range both fields are empty).

  • If not obvious, what U expected to happen: field should be empty
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Always attach - Diagnostics file, Killswitch processes list, dump (if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- CIS version & configuration: 6.0.260739.2674, own config

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: all
  • Have U made any other changes to the default config? (egs here.): sure
  • Have U updated (without uninstall) from a previous version of CIS: no
    [li]if so, have U tried a a clean reinstall - if not please do?: no
    [/li]- Have U imported a config from a previous version of CIS: no
    [li]if so, have U tried a standard config - if not please do: no
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: XP Pro, SP3, 32b, admin
  • Other security/sandbox software a) currently installed b) installed since OS: none

Files attached inc diagnostics, config, processes - PM for pwd.

[attachment deleted by admin]

Confirmed. t would make more sense to use a empty field.

It’s either 65533 or 65535 that is the last port that is usable, that might be the reason?

No. The last usable is 65535, field is set to 65533.

Empty or 0, CIS does not hold standards on this ground. In port range fields are empty, while adding port to portset fierlds are 0.

I won’t even mention that adding IP keeps the leading 0s…

Well I did have that in my post. Anyway, was just a thought.

PM sent

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


2708 - fixed

Not tracked so not updated.