'Website Filtering' does not block HTTPS in Google Chrome v43 [M1492]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, configuring web filter to block certain websites.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: I set filtroweb to block a term any *.com.
2:. Even after rebooting, and browse a page any sites with the term * .com appears
3: Based browsers code chromium shortly after the release 36.xx. To be more specific from version 40 web filter failure URL filtering, if and only if, we are sailing in the open source browsers chromium release: 40
One or two sentences explaining what actually happened:
FiltroWeb not filter custom settings, open source browsers chromium release: 40
One or two sentences explaining what you expected to happen:
COMODO should be able to filter URLs in any web browser
[B] If the software compatibility problem have you tried the advice to make programs work with
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
Apparently CIS is not capable of filtering URLs (open source browsers chromium release: 40) . Even excluding all the default configuration of web filter, comodo internet security fails.

Exact CIS version & configuration:
Comodo Internet Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus active (statefull verification)
Active HIPS (secure)
Active firewall (secure)
active web filter (custom mode)
Active Sandbox (standard mode)
Have you made any other changes to the default config? (egs here.):
I changed only the web filter settings, excluding the predefined policies and configured to block addresses with the term (* .com)
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
It has been a clean installation
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
Yeah, so I tried to delete the web filter default settings
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows tecnical priview 10 and windows 8.1 single language, active UAC, real machine
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=no b=no

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
It is not necessary.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Currently latest version of Vivaldi is using Chromium v44 (Dragon is using Chromium v43) so I’m guessing this is less of an issue with Chromium and more of an issue with Vivaldi.

Actually, I’ve tested latest Chrome and there seems to an issue.

Just tested and you’re right, although it doesn’t seem to be Chromium 40 but rather Version 43.0.2357.130 and up (Dragon is Version 43.0.2357.81 and it’s being blocked just fine)

Edited. Thanks.

Or perhaps it is in v40 too but it’s dependant on something that Comodo disables?

I did not test the issue in-depth but it seems probable. Dragon should ensure backward compatibility with the virtualization component.
Do you experience anything different (eg improvements compared to Google Chrome ) regarding virtualization process in Bug 669 ?


I do not experience anything different between Google Chrome and Comodo Dragon in regards to bug 669 however I do not think the bug reported in this topic is depending on virtualization.

I would like to report that this is fixed in version both google and firefox will not connect to https:// sites when creating a block rule that contains https://*

Thank you.

In that case, I will move this one to “Resolved” section.
Thanks again.

Personally don’t have an issue with Chrome but it doesn’t filter Vivaldi.

Please create a separate report for that one.