Want to install CIS v6.3.32439.2937 but it freezes my Win7 64bit Home Premium PC

Hi Guys

Been a longtime fan of Comodo products. Due to CFW not working with iTunes I swapped it out a year ago but now with a new laptop Im trying again. Been trying most of the day to install the latest CIS / CFW but it freezes my laptop on booting into the desktop. There must be a conflict but I cant isolate it. I have MBAM Pro with the protection module disabled and Hitman Pro on demand. Is there a list of apps that are incompatible / cause conflict I could check against please?


Which version of Windows are you using?

Also, which version of CFW did you install?

Hi Chiron

Thanks for coming back, I downloaded the latest version of CIS from the website today (v6.3.32439.2937) and am running Win7 Home Premium 64bit Sp1 fully hotfixed. Similarly tried CFW v.6.3.39654.2953.


Strange. In that case perhaps something went wrong with the installation. To rule that out please reinstall CFW by following the advice I give in this topic. Be sure to also run the removal tools for old malware programs, as suggested in that topic.

Let me know if there is any change after doing that.


Many thanks Chiron, followed all that and it works now! Legend!

Interestingly the free download link didn’t give me a choice on a 64bit installer, I might have been installing the 32bit installer ‘cispremium_installer’ rather than the ‘cispremium_installer_x64’ which I’ve now found and installed and works. Duh! :-La

Either way, thanks so much for your help,


Great to hear that everything’s now working. Let me know if you have any other questions/problems.